site  contact  subhomenews

Wireless keyboards not working

August 02, 2009 — BarryK
I'm puzzled about this. Recent 4.3 alpha and pre-beta testers have reported their wireless keyboard and mouse not working. But it does work with the older kernel. All the recent 2.6.29.x and 2.6.30.x kernels, they do not work.

I don't know why, no one has been able to provide me with any clues other than "it doesn't work".

I'm going to Perth tomorrow, so I guess I will buy one -- I don't really need it, but this is an issue that has to be resolved. My favorite PC parts supplier, PLE, has these for $49:

Gee, I hope that having one of these things in my possession does help me to resolve this. Perhaps I have misconfigured something in the kernel? At this stage I have no idea.

Has anyone compiled a recent kernel for Puppy, and they do have a wireless keyboard working?


Microsoft keyboard
Username: BarryK
Unfortunately, the Microsoft wireless keyboard is only $39: I hate it that MS is into selling hardware, so I will take a stand and not buy it.

wireless keyboard works
Username: dogone
"For what it's worth Barry, one of my machines has always experienced wireless keyboard/mouse detection issues with Puppy, that is until 422 (k2.6.30.1). 422 just works on that troublesome system. The problem appears to relate to Xorg configuration at initial boot and the age/type of motherboard BIOS - not to the interface employed. Bottom line: don't jump to any conclusions re short-comings in 422. Do ask that those reporting the problem communicate precisely when control is lost. This is key.

wireless keyboard
Username: Jota
"At the moment I don't own any wireless keyboard, but yes I also think the clue could be on the BIOS, not on the kernel config. Really more info from testers needed here.

Username: 01micko
"I think tasmod had his wireless keyboard going in Slaxer_pup by big_bass, k2.6.27.7 if I remember... It was basically 412 with the Slackware 12.2 kernel (patched) dropped right in. PM big_bass. It had some issues but generally HW support was very good.

wireless keyboard + mouse
Username: peterw
"Have tried both upup-476 and ppa-422 (As a live CD) on a machine with an Abit SG-80 motherboard and Logitech wireless keyboard and mouse. It all works fine for me. The reported problem is most likely with some peoples bios since with my setup the keyboard works as I type in "puppy pfix=ram" and the linux system has not loaded at that point? As an aside would it be possible to keep the 4.2 calendar and clock on the desktop in the new puppy versions? It is useful for me and I think it balances up the display making the desktop more attractive.

When they stop working
Username: BarryK
"What people are consistently reporting is that their keyboard does work at the first boot prompt, that is the syslinux/isolinux display. It stops working when the choose-your-keyboard-layout dialog appears, that is, after Linux has loaded. So, it has nothing to do with X, probably nothing to do with the BIOS either, it's a kernel problem. It is likely that the 2.6.27.x kernel is ok, that's my gut feeling. I reckon the trouble starts with either the 2.6.28 or 2.6.29 kernels. Although I said that I won't buy that Microsoft keyboard, I see the darn things everywhere. MS keyboards and mice are the biggest sellers here, the local Perenjori Telecentre has them (but I'm always in such a rush there, as I pay by the hour, can't really do testing). If Puppy users have those keyboards and they aren't working, then I guess I'll have to buy one.
Username: BarryK
"dogone, Note, 4.3pre-beta also known as '422', was uploaded with the and kernels. I had to roll back from 2.6.30.x as cdrkit and cdrtools do not work properly with it.

Wireless Keyboard + Mouse
Username: peterw
"Clarification of my earlier missive My logitech wireless keyboard and mouse keep on working fine even if I do a Cntrl Alt Backspace and xwin to get the window back as I have done here when running ppa 422. They work fine in Abiword and I am typing this with ppa422. They obviously worked fine when I selected my keyboard. Hope this is useful. Regards

Wireless Keyboard issue
Username: tasmod
"Don't go out of your way on my account Barry. I use a Logitech wireless keyboard setup. The trouble is where do I start to investigate ? I reported before that the initial startup allowed me to type in pfix etc but once the kernel was loaded then the keyboard stopped. I think you made changes to the init file which suggested at that point it stopped working. I needed somehow to get full verbose feedback during loading to see whre it fell down and as i do not know how to get that I'm stuck. At the moment the only clue I can give is that ppa422 keyboard doesn't work and pps422 it does.

Wireless keyboard
Username: B
m"I never had a problem with any of the puppy and similar distros with my wireless keyboard and mouse which came with my Medion MD 8818 PC."3 Aug 2009, 4:28"00939'wireless keyboard"kirk"[b]What people are consistently reporting is that their keyboard does work at the first boot prompt, that is the syslinux/isolinux display. It stops working when the choose-your-keyboard-layout dialog appears, that is, after Linux has loaded.[/b] I have this problem with Fatdog, at least the 64bit version I'm working on with If you unplug and plug back in the adapter, then it works. I guess this is because pup_event_front looks for a uevent to happen. The modules that load for me is joydev.ko and hid-sunplus.ko. Both together are about 23k. I'll probably add it to my initrd.gz. Maybe others can check what modules are getting loaded.

Logitech EX100
Username: BarryK
"I have purchased a Logitech EX100 wireless keyboard and mouse, and I can verify that Ppup with kernel it works, but not with kernel. I haven't tried the kernel but it is probably the same situation. The same usb related modules are loaded in both cases, but looking at the boot log in /tmp/bootkernel.log, for the kernel the Logitech keyboard and mouse are recognised, but not with the other kernel. It sure is weird. I'll try what kirk suggested, see if anything extra loads if I replug it.

wireless hardware dependency
Username: dogone
"As evidence that boot-time wireless detection is hardware/BIOS dependent, I can share that on my problematic system, the EX100 *does not* work with k. (412), while it *does* work with (422). Functionality varies among older Puppies and derivatives (ttuuxxx's 214R works fine as does Gray's latest NOP release). This all suggests to me that other factors are at work as well. I'd be happy to PM a hardinfo report from said system.

whd follow-up
Username: dogone
"I just went through my stack of old Puppies and I must reveal that I cannot now reproduce the above results. Every disk boots with keyboard and mouse working (Logitech EX-110, buy way). And this prompts another thought. The machine in question dual-boots XP. Is it possible for Windows to leave the EX-110 in a state different than "out-of-the-box"? Power to the keyboard's transceiver is after all, maintained 24/7. Last thought. On no occasion has keyboard control been lost prior to Puppy's boot options menu. On either no occasion or very few, has keyboard control been lost prior to Puppy's initial configuration (Xorg) screens.

Tags: woof