site  contact  subhomenews

Sane-backends 1.0.21

June 20, 2010 — BarryK
I already compiled libusb 1.0.8:

I have recompiled sane-backends in Quirky, now using both the old libusb 0.1.12 and the new libusb 1.0.8.

'perthie' reported that the libusb-compat package is needed for the Canon driver. Hmmm, that is very odd. I am not going to risk taking out libusb 0.1.12. If that really is the situation, then the Canon driver is broken.


Username: Firewave
Strange. In 1.1 my Canon scanner was working by using the updated sane-backends and xsane packages you posted before the 1.2 release. No need for additional packages. It's from the imageCLASS/i-SENSYS series, that is using the pixma driver."20 Jun 2010, 12:54"01671"'Just for MPxxx Scanners?"perthie"I suspect that the problem is in the firmware of certain MP class Canon machines. Both the MP250 and MP490 need the libusb upgrade, and even Canon's own scangearmp scanning software won't run in Puppy without it. Username: 20 Jun 2010, 19:33

Tags: quirky