site  contact  subhomenews

JWM reload menu without flicker

January 01, 2012 — BarryK
01micko reported that JWM now has the '-reload' option, that reloads the menu only, without restarting jwm itself. This avoids the screen flicker.

01micko reported on modifying scripts in the PPM to take out the "screen will flicker" message if JWM version is greater than 547:
http://www.murga-linux.com/puppy/viewtopic.php?p=590227#590227

Don't use 01micko's 'jwm-update-553.pet' as it has bugs -- I fixed it and posted the scripts to Woof:
http://bkhome.org/fossil/woof2.cgi/info/c90cc1a6f0

I compiled JWM version 562 in Wary, uploaded here (75KB):
http://distro.ibiblio.org/quirky/pet_packages-common/jwm2-562-w5c.pet

Comments

reload


jwm reload
Username: technosaurus
"Simpler fix. jwm -reload jwm -restart

Wary and Racy
Username: BarryK
"DaveS, Yes, it is intended that all packages compiled for Wary will also work in Racy. In fact, the JWM PET should work in all puppies, which is why I put it in the 'common' repo.

jwm compile, same here
Username: pemasu
"In dpup squeeze the same thing. 01micko believed it might be due to too old pixman and maybe libpng. Maybe gtk version affects also, which is also old in dpup. JWM revision 512 is the latest without black squared boxes. Rev 512 does not have -reload function yet. Too bad.

jwm 562 test
Username: pemasu
"Previously I tested by updating pixman from sid and the result was washed out icons in menu. Now I tested with pixman from wheezy and now icons in menu are ok. Possible side-effects....not sure yet. pixman version in wheezy is libpixman-1-0_0.24.0-1_i386.deb # jwm --version JWM vsvn-562 by Joe Wingbermuehle

no, jwm 562 failed still
Username: pemasu
"It was just Aurora theme which accidentally looked ok. All the other themes (which I tested) had washed out colors. Back to the starting point. I will leave this for awhile in dpup now. Back to the 505.

Ok in Racy
Username: BarryK
"JWM version 562 with -reload seems to work ok in Racy 5.2.2. Both Racy and Wary have pixman 0.22.2, which is pretty recent. Hah hah, just as I was typing this, the JWM menu and tray went all washed-out! So much for this new feature of JWM! Will someone volunteer to tell Joe (the JWM developer)?

no probs on Slacko
Username: 01micko
"I just did 'jwm -v' to see what I was running! 562, I compiled it when it came out and have not had an issue. Current version of pixman: 0.20.2 Joe is at 569 as of the last 24hrs

JWM washed out on Racy
Username: BarryK
"On Racy, the window, menu and tray controlled by JWM remained normal after a -reload operation for a little while, then all of a sudden became "washed out", but the really weird thing is, after a reboot it is still washed out. Not just the icons, all the colours too. I replaced /usr/bin/jwm with version 505, restarted X, and the icons are back to normal, but the colors are still wrong, as before. Hmmm, try a reboot... nup, the colours are still wrong. I had to reselect the "DeepBlueBold" JWM theme in the "Desktop" menu, then got the correct colours back.

JWM bug reported
Username: BarryK
"I have reported it: http://sourceforge.net/tracker/?func=detail&aid=3469369&group_id=157836&atid=805416

jwm-574
Username: 01micko
"From the changelog: [i]2012-01-14 16:18 joewing * [r574] /src/icon.h, /src/render.c: Change the way alpha transparency is handled.[/i] Maybe the icon issue is fixed? Still fine in Slacko.


Tags: woof