Assorted bugfixes

HairyWill posted a patch for Pwireless. This project was created by plinej, so ordinarily any changes should go through him, however this is just a one-line simple fix, so I put it in. I have named the package 'pwireless-0.8.1' and I'll upload it soon.

HairyWill reported the menu icon missing for Glade-3 (Utility menu). I have put the icon into /usr/share/pixmaps and fixed the .desktop file. This is in the 'devx' file.

I think it was HairyWill also who raised the problem with 'vi'. This is a script, at /bin/vi, which just echoed some text and did nothing else. Not satisfactory. I have deleted the script, and in /etc/profile I have put 'alias vi=e3vi' which causes 'e3vi' to run. 'e3vi' is a symlink to 'e3' and starts e3 in vi-simulation-mode.

Note, I couldn't just put /bin/vi as a symlink to /bin/e3vi as e3 would not then start in vi-simulation-mode.

Forum member Feverfew created a couple of replacement images for the "welcome, woof, woof" window. They had the Citrus theme and Feverfew created them in the Gradient-grey theme. I created the 'menu2.png' myself, and used 'taskbar.png' supplied by Feverfew.

HairyWill reported that PCM volume setting was lost after a reboot when he choose fast-boot. Actually, this has been a generic problem with Puppy, fast-boot or not, right from Puppy version 0.1. Puppy only restores the master volume at startup.

I have finally fixed this one. The shutdown script, /etc/rc.d/rc.shutdown, runs 'alsactl store', which saves the settings to /etc/asound.state. I have added 'alsactl restore' to /etc/rc.d/rc.sysinit (for the fast-boot) and to /etc/rc.d/rc.local0.

Posted on 27 Apr 2008, 19:06


No comments posted yet.