Modem problems in 4.1alphax

Rerwin (Richard) reported a problem with the LT modem device node when using 'wvdialconf'. Puppy 4.1alphax uses wvdial version 1.41, chosen for its small size. I have changed to version 1.53, so we shall see if that improves the situation.

Rerwin also reported error messages about unknown symbols when loading the 'slusb.ko' module. I discussed this awhile back in this blog -- slusb is not GPL and I hacked the code (can't recall what I hacked, but I probably wrote something in the blog at the time) to get it to compile. But now rerwin is reporting it won't load, so it is still not able able to use those USB GPL symbols -- I don't know why, as it compiled ok.

Anyway, I think that I will have to leave slusb.ko out of 4.1alpha3. Unless or until the Smartlink developers can create a GPL slusb.ko.

Oh, here is my earlier post on slusb:
http://www.puppylinux.com/blog/?viewDetailed=00099

Posted on 25 Jun 2008, 8:10


No comments posted yet.