2.6.25.9 kernel, madwifi

Ha ha, the Unionfs people have not responded to my bug report, so I decided to wait no longer -- I can repatch the kernel later if/when they do fix the bug and hopefully I won't have to recompile all the other modules. But I thought that I had better check kernel.org to make sure I have the latest version -- 2.6.25.9 has just been posted. Man, these updates are coming fast! It shows that there are a lot of issues with the 2.6.25.x kernel. Well, 2.6.25.9 is the one I'm going to use, and I hope it is debugged enough as I want to stick with it for sometime.

Note, I also downloaded madwfi v1.9.4. The kernel has ath5k but Ted Dog reports the old madwifi drivers work better -- but then we don't really know, perhaps the 2.6.25.9 kernel has fixed problems with the ath5k driver, just as they have fixed mac80211 issues (apparently). Anyway, I'll compile madwifi but will blacklist the drivers so they aren't loaded by default.

I also got the latest aufs out of CVS today.

Posted on 25 Jun 2008, 8:32


Comments:

Posted on 25 Jun 2008, 10:26 by Rarsa
Other distros have problems with that kernel
Kernel 2.6.25.x has had problems with wireless in other distros.

Actually in my Fedora installation it totally broke it so I'm using the previous kernel until it gets fixed.

I think that my particular case has already been fixed in a test kernel so I'm waiting for it to go to the main repository.


Posted on 25 Jun 2008, 10:50 by Ted Dog
compress Ram swap
A RAM based compression swap patch. Instead of swaping to disk this would compress in RAM for rapid access.

http://code.google.com/p/compcache/

I agree with Rarsa, I have yet to find newer working kernel for wifi.

The last kernel for Knoppix DVD was the highest numbered kernel which everything worked.





Posted on 25 Jun 2008, 11:54 by SouthPaws
Knoppix 5.3.1
http://distrowatch.com/table.php?distribution=knoppix

The kernel was in the 2.6.24.x series.


Posted on 25 Jun 2008, 22:52 by Bosco Bearbank
madwifi drivers
The ath5k driver doesn't work for me in any kernel, including the most recent Fedora kernel (2.6.26-0.90.rc7.git2.fc10). Furthermore, (and I don't know if it's relevant) there appears to be a bug in the madwifi package as found at livna.org that prevents it from building:

25 Jun 09:24:00 akmodsbuild: /tmp/akmodsbuild.V5kOgEFk/BUILD/madwifi-kmod-0.9.4/_kmod_build_2.6.26-0.90.rc7.git2.fc10.i686/net80211/ieee80211_power.c: In function 'ieee80211_pwrsave':
25 Jun 09:24:00 akmodsbuild: /tmp/akmodsbuild.V5kOgEFk/BUILD/madwifi-kmod-0.9.4/_kmod_build_2.6.26-0.90.rc7.git2.fc10.i686/net80211/ieee80211_power.c:240: error: implicit declaration of function
'__skb_append'
25 Jun 09:24:00 akmodsbuild: make[3]: *** [/tmp/akmodsbuild.V5kOgEFk/BUILD/madwifi-kmod-0.9.4/_kmod_build_2.6.26-0.90.rc7.git2.fc10.i686/net80211/ieee80211_power.o] Error 1
25 Jun 09:24:00 akmodsbuild: make[2]: *** [/tmp/akmodsbuild.V5kOgEFk/BUILD/madwifi-kmod-0.9.4/_kmod_build_2.6.26-0.90.rc7.git2.fc10.i686/net80211] Error 2
25 Jun 09:24:00 akmodsbuild: make[1]: *** [_module_/tmp/akmodsbuild.V5kOgEFk/BUILD/madwifi-kmod-0.9.4/_kmod_build_2.6.26-0.90.rc7.git2.fc10.i686] Error 2
25 Jun 09:24:00 akmodsbuild: make[1]: Leaving directory `/usr/src/kernels/2.6.26-0.90.rc7.git2.fc10.i686'
25 Jun 09:24:00 akmodsbuild: make: *** [modules] Error 2

However, recent svn snapshots of the madwifi driver build and work for me (I'm currently using madwifi-trunk-r3744)