faac, faad, x264, xvidcore, ffmpeg

I have been inspired by plinej, who has recently been through this exercise. Earlier, there have been requests to support faac, faad, x264 and xvidcore codecs, so here it is -- these are all dependencies of ffmpeg.

For the record, here are my compile notes:

faac-1.26
----------------------
# ./bootstrap
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu
# make
# new2dir make install

faad2-2.6.1
-------------
# ./bootstrap
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu
# make
# new2dir make install

yasm-0.7.1
--------------
x264 needs this to compile.
# ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --build=i486-t2-linux-gnu --disable-python --disable-debug
# make
# new2dir make install

x264-20080731-2245
---------------------------
tricky, installs to /usr/local, have edited 'configure', changed prefix='/usr'
# ./configure --enable-gtk --enable-shared --host=i486-t2-linux-gnu
# make
# new2dir make install

...note, the executables got linked statically with the libx264 library, so have removed them from the PET package, just kept the shared lib as that is what ffmpeg needs.

xvidcore-1.1.3
------------------
# cd build/generic
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu
# make
need some trickery...
# cd ..
# ln -s generic xvidcore-1.1.3
# cd xvidcore-1.1.3
# new2dir make install

now we have all the dependencies....

ffmpeg-20080731
----------------------
problem, needs a utility called 'pr' -- I got it out of coreutils, put permanently into Puppy.
problem, busybox 'od' utility, missing option '-A' -- coreutils again, permanently into Puppy.
# ./configure --prefix=/usr --cpu=i486 --enable-libmp3lame --enable-liba52 --enable-libxvid --enable-libx264 --enable-libfaac --enable-libfaad --enable-pthreads --enable-small --enable-libvorbis --enable-gpl --enable-shared --disable-static --enable-swscale --enable-postproc --disable-debug
# make
# new2dir make install


Posted on 3 Aug 2008, 9:43


No comments posted yet.