'devx' works in Woof

It took much of today chasing dependencies, but I finally got the 'devx' SFS file to work in Woof.

What prompted me to get 'devx' working is I wanted to compile Xfce4-panel. The Ubuntu version reports an error, many times:

(xfce4-panel:18343): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

I searched on the Internet and found a report, the same error with the Ubuntu Network Manager, and they fixed it by updating the GTK icon cache:

# gtk-update-icon-cache --force /usr/share/icons/hicolor

However that did not fix it in my case.

So, I recompiled Xfce4-panel (4.4.2), to see if that makes any difference. No, still get the same error message.

Note, despite the error mesage, Xfce4-panel still runs.


Posted on 15 Dec 2008, 18:10


Comments:

Posted on 15 Dec 2008, 23:23 by magerlab
xfce4.4.3.pet
Gray has already made a pet for xfce4.4.3 (just 4mb!)
http://murga-linux.com/puppy/viewtopic.php?t=35193
works quite fine


Posted on 17 Dec 2008, 15:12 by inged
SFS without booting?
Something that can speed up SFS creation and testing could be as claimed by this people: http://hacktolive.org/wiki/SFS_Technology

From the short description seems like SFS files that run without booting, seems pretty interesting, just run what you need now without loading all SFS files!

That way you can create an extreme light system where the end user will use whatever SFS they prefer, you can play with the inner workings of puppy while community will address everyones taste



Posted on 19 Dec 2008, 19:36 by BarryK
Error not fixed
I would like to append a comment to this thread, as it seems the above-reported error message was not actually fixed by any of the reports I read on the Internet.

This bug is mostly occurring to Ubuntu users, some Fedora.

I think that it is reported on the Internet when there was some other reason for an application crashing or not starting, and when they listed the errors, "my error" was in there. But, when they fixed the crashing-error they were then happy.
However it is likely that "my error" is still there.

I could not find any report anywhere that addresses the error message that I have reported. I guess that I would have to go to the Glib developers to find out, but I can't be bothered. I'm not using Xfce4-panel now so don't care anymore.