Grrr

Just got a big screen flicker, running Woof off USB Flash drive. I have a 'tail -f /tmp/xerrs.log' running, and this time did not get the "pipeline underrun" error. Curses, there seem to be two separate bugs!

I wondered if HAL was to blame, so have emasculated it. The 'hald' daemon is still running but doing nothing. So it would seem HAL is not to blame.

When I stated that the screen flicker and the pipeline underrun errors are periodic, actually I can't find any pattern. When I stare at the screen waiting for them, they don't happen. But then they will suddenly happen for no apparent reason.


Posted on 24 Jan 2009, 16:21


Comments:

Posted on 24 Jan 2009, 17:37 by Sage
"When I stare at the screen waiting for them, they don't happen."
This is a very well-documented effect amongst the technologies. I ascribe it to photon feedback from your brain via the eyeballs. Try viewing the screen over your shoulder through an half-silvered mirror. Works for me - sometimes. But then again, sometimes not...
[What do you expect on slow a Saturday morning?!]


Posted on 25 Jan 2009, 4:18 by prehistoric
buffers
This is a situation where really nasty concurrency problems can show up, because you have two unsymmetrical processors, but can only control one directly. Before we start arguing about the effect of observation and which part of the multiverse you occupy, we should consider that when you are watching, you aren't affecting processes which may result in a glitch later. If this delay is long enough, it will escape from your own limited buffer for connecting events.

Two different situations are likely to do this: 1) filling or emptying a large buffer; 2) coincidence in periodic events started with varying time between them. Not directly controlling that GPU makes this one a bitch to trace. In bygone days when we were using less integrated electronics, I remember noticing that someone had such a problem by counting the number of discarded PROMs in a pile next to the graphics board.


Posted on 25 Jan 2009, 6:32 by dionicio
Why why ubuntu?
Why not debian?

I am not programmer,
but I know for sure that Ubuntu
is disrespectfull of my disk partitions.

Maybe the code responsible of this
will not be part of woof

but the trust chain of Ubuntu is broken
at some unknown point.



Posted on 27 Jan 2009, 8:49 by ottod
Flicker is due to Xorg
I have been an Ubuntu user since 4.10, and a Puppy user since 2.1x.
Right now I experience the same problems you have in Woof but I am using standard Xubuntu 8.10 with the Intel video driver. Things broke in this release (they were ok in 8.04) and they are supposed to get fixed in Jaunty. Supposedly kernel 2.6.28 + new Xorg will put things back on track. It is something about memory management in video drivers (TTM vs GEM + kernel space modifications present only from 2.6.28 and up)
See this:
http://www.phoronix.com/scan.php?page=article&item=xorg_74_final&num=1