PPM now fast

Divide and conquer! The Puppy Package Manager is now very fast. I have alphabeticised the display, with the option of "ALL" if required:



I am aiming to keep the GUI window within 800x600, and this one is 776x557 -- maybe I could allow a bit more height for the installed-packages window.


Posted on 4 Mar 2009, 21:03


Comments:

Posted on 4 Mar 2009, 21:52 by capoverde
Dreamlike!
Gee, Barry... this looks like a dream. Another great job, thanks a lot! (Since Puppy 1.08 all your work has been greatly appreciated here).


Posted on 4 Mar 2009, 22:52 by happypuppy
Great,but...
Great,but there's one thing I don't like about the Puppy package manager.

As soon as you click on a package entry,the packager immediately executes the install/uninstall process.

I'd like to click on a package to select (highlight) it first and then double-click (or click again on the selected item) to install/remove the package.

That's much more user-friendly and avoids accidental actions.



Posted on 4 Mar 2009, 23:07 by dogone
PM window
A significant improvment. I suggest allowing the "installed packages" window one third of the vertical space and widening it by shrinking the two buttons (perhaps "Configure PUPS", "Exit PUPS").

Anothe approach would be to employ a single window and highlighting packages already installed. I can imagine one failing to find a repository package simply because it's already installed and buried in the "installed" list. One list would be cleaner.


Posted on 5 Mar 2009, 4:40 by puppymike
PPM on Eee901
Great stuff! Looks like magic to me.

Remember Netbooks e.g. Eee901 are 1024x600 for fitting windows.

Also I agree with happypuppy regarding more warning if possible before installations.




Posted on 5 Mar 2009, 7:44 by BarryK
Warning
As soon as you click on a package entry,the packager immediately executes the install/uninstall process.
Ah, you haven't tried the new package manager. It is a complete rewrite -- when you click on a package you get a window with further information on the package and asking to confirm if you want to install (or uninstall). This is explained I think in the web page I wrote recently introducing the new PPM.

Note, I have also added a "Download only" button, as requested.




Posted on 5 Mar 2009, 11:53 by happypuppy
Re:Warning - package manager
But is that the case with the one in Puppy 4.2?

It would be really nice if the old package manager gets a fix before the release of Puppy 4.2.



Posted on 5 Mar 2009, 11:57 by happypuppy
Re:Warning - package manager
That's great to hear,but I was talking about the older one available in the 4.x series.

It would be really nice if the old package manager gets a fix before the release of Puppy 4.2.
(most users will be using that version)



Posted on 6 Mar 2009, 4:59 by disciple
Could it be resizeable?
It is good making things to fit on small screens, but it would be a lot better if they were properly resizeable - I don't know whether the new version is the same, but if you maximised the old version the lists didn't actually get any bigger.