Arch bugs fixed

Oh, that's a headache. It seems that only one package, amarok-engine-xine, uses variable substitutions for the 'pkgname' (in PKGBUILD file):

_enginename=xine
_origname=amarok
pkgname=${_origname}-engine-${_enginename}
pkgver=1.4.10
pkgrel=1
pkgdesc="${_enginename} engine for amaroK"

...which causes 0setup to spew out a heap of error messages.

Well, it's to complicated to fix, and since only one maintainer has done this, I'm simply going to filter-out that package.

It seems to be working now. Two files have been changed, '0setup' and 'DISTRO_PKGS_SPECS-arch'. I have uploaded as 'woof-alpha3.1.tar.gz' here:

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/test/woof-alpha3/

I rather like Gedit. I'm thinking that I might put 'gconf' and it's dependencies into the Arch and Slackware builds, just so I can be consistent across all builds and have Gedit as the text editor.

Maybe Michael and anyone else doing an Arch (or Slackware) build, checkout what packages are needed to support my Gedit PET package. If you install Gedit, it will report that 'gconf' is needed plus it's deps, and hopefully that won't be too big.


Posted on 23 Mar 2009, 19:26


No comments posted yet.