Todo list for alpha6

There's plenty to do. This for a start:

1. Bring in rerwin's work on 3G modem support.
2. Puppy Package Manager needs work -- reports alpha4 not all deps getting installed for some pkgs.
3. Reconsider the Ubuntu Pppoeconf package.
4. Compile latest ffmpeg/xine/gxine (Ubuntu too many deps, alpha5 I used pup 412 pkgs).
5. Recompile kernel, suggested config changes, try get more modem modules to compile.
6. Upgrade JWM to latest nightly snapshot, modify theme to true flat grey.
7. ROX-Filer maybe compile latest.
8. Vala 0.7.1 for devx, has Genie fixes.
9. Improvements by John Doe to 0setup script.

1. 3G modem
Rerwin, if you read this, I haven't been following the progress recently, has it reached a point where I can put your fixes straight in to alpha5? Alpha5 is basically 412 plus your modem patch pet, as described in a recent blogpost.

3. Pppoeconf
This is an Ubuntu package, that I modified awhile back to work in Puppy 412:
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/pppoeconf_pup-1.17.pet
Anyone who uses PPPOE want to check that package out in alpha5? I personally don't use PPPOE so any help here is appreciated.
But, perhaps the original Ubuntu pppoeconf .deb package will now work, maybe try that first.

7. ROX-Filer
On my Ntavo, Rox failed, got an error message "process not responding" when the desktop was starting up, and so got JWM ok but a black desktop. Was able to start Rox filemanager after that. Maybe a problem with the limited RAM? Probably time to compile latest Rox anyway.


Posted on 23 Apr 2009, 8:41


Comments:

Posted on 23 Apr 2009, 8:15 by Dingo Dog
netgear WWG311v3 wireless adapter
Hi Barry

I would add a possible to do to list

From Puppy 4.1 I'm not able to get worging my wireless adapter NETGEAR WG311v3 (via ndiswrapper, because its chipset is unsupported natively in Linux)

in older puppy versions was worging dine

What do you think about?




Posted on 26 Apr 2009, 17:43 by Terryphi
Extra libs needed for Opera
Opera browser needs these libs:

libqt-mt.so.3 symlink to libqt-mt.so.3.3.8

libaudio.so.2 symlink to libaudio.so.2.4

As lots of Puppy users add Opera it would be very helpful if these libraries were added to Upup.


Posted on 27 Apr 2009, 10:56 by happypuppy
Opera and Upup
Try the Opera 10 Qt4.5 .PET by synth:

http://www.murga-linux.com/puppy/viewtopic.php?t=41335

It works fine without those libs.

If you use the latest Qt, you don't need those dependencies.



Posted on 27 Apr 2009, 13:53 by Terryphi
Extra libs needed for Opera
happypuppy: I always download the .deb file from the official Opera site and install it directly into Upup. The official .deb files use qt3.

I think Upup should support the official .deb files. This is the way to go for Woof.


Posted on 27 Apr 2009, 24:01 by UnixUser
Users Support
Dear all,
I have been using Puppy on an old pentium 4 2.4GHz because Ubuntu is kind of slow there. For the rest of my 64bit 8GB RAM desktops i use Ubuntu.

The problem is that permissions completely change in Puppy as Puppy default log in is the root user. Is there anyway of allowing puppy to support User accounts and include an X-based login manager?




Posted on 28 Apr 2009, 16:42 by Terryphi
Optionally use UTC time on the HW clock
Pizzagood has a very interesting post and patch on the forum:

http://www.murga-linux.com/puppy/viewtopic.php?t=41680

This would be very useful for Linux dual boot and maybe it could be added to Woof.

I haven't tested it myself on Upup because I have done a fix on Ubuntu which solves the problem for my dual boot Upup/Ubuntu system.