Vala compiler upgraded

The 'vala' package provides the Vala and Genie compiler. The 'libgee' package provides support for advanced data types in Vala/Genie. The 'valide' package provides a IDE for Vala/Genie programming, with a colour-syntax-highlighting editor.

I have compiled these in Jaunty pup:

libgee 0.1.5
vala 0.7.1
valide revision 181 (from svn on 28 April 2009)

The libgee runtime shared library is in the main Puppy filesystem, vala and valide are in the 'devx' file.

Note that valide has a patch script that patches /usr/share/vala/vapi/gtk+-2.0.vapi in the vala package.

Note also that Vala 0.7.1 fixes some Genie bugs that were reported earlier in this blog and on the forum.

For those who want to know more about Vala/Genie, see my earlier blog posts:

http://puppylinux.com/blog/?viewDetailed=00494
http://puppylinux.com/blog/?viewDetailed=00499
http://puppylinux.com/blog/?viewDetailed=00656


Posted on 29 Apr 2009, 21:16


No comments posted yet.