e3 text editor fixed

It was reported in alpha6 feedback that the little 'e3' text editor crashes, with a segmentation fault at startup. e3vi is what gets launched if you type 'vi' in a terminal, where e3vi is a symlink to e3 and starts e3 in vi-compatibility mode.

e3 is written in assembly language and is tiny, 13KB. It is static and runs independent of any libc. I have it in two places, in the initial ramdisk and in the main Puppy filesystem, at /bin/e3.

It is the Ubuntu e3 (version 2.7.1) that crashes. How they have managed to get such a simple application to crash I don't know. It looks like the same package as in Debian.

Puppy 4.x has e3 version 2.7.0, compiled back in January 2006. That works fine. I grabbed the latest, 2.7.1, and compiled it in Jaunty pup, that works fine too.

So, now using my own e3 PET package for Jaunty pup.


Posted on 11 May 2009, 8:02


No comments posted yet.