Fixes for Puppy-Puppy

I am doing some work on the Woof Puppy-Puppy build. That is, Puppy built from Puppy PET packages rather than a compatible distro. For now it is 4.1.2 packages.

DISTRO_PKGS_SPECS-puppy
The file DISTRO_PKGS_SPECS-puppy had some errors. The third field is the name of one or more packages, and needs to be a name-only without version number, or if it does have more than just the name then it must be suffixed with a wildcard. For example, I had this line:

yes|absvolume_puppy|absvolume_puppy-0.8|exe

Which was okay in an earlier version of Woof but now must have the explicit '*' wildcard:

yes|absvolume_puppy|absvolume_puppy-0.8*|exe

3builddistro
A fix was required due to the absence of any compatible-distro database packages. That is, the script got a little bit confused by the "compatible distro" being a previous release of Puppy rather than a different distro.

findwoofinstalledpkgs.sh
The file /root/.packages/woof-installed-packages is a database of all builtin packages. There was a bug in this file, every entry was duplicated.
3builddistro calls /usr/local/petget/findwoofinstalledpkgs.sh (as does the CD remaster script) to create woof-installed-packages.
The script got a little bit confused by the "compatible distro" being a previous release of Puppy rather than a different distro. Fixed.


Posted on 28 May 2009, 8:23


No comments posted yet.