Library upgrades for Puppy2

I got frustrated as wanted to compile various applications but GTK in Puppy2 is too old. So, I "went to town" on Puppy2, upgrading all of this (in the order shown)...

libtool 2.2.6

pcre 7.8
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --enable-utf8 --enable-unicode-properties

glib 2.18.3
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --disable-selinux --disable-fam --with-pcre=system

pixman 0.12.0
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --disable-sse2 --disable-vmx

cairo 1.8.6
# export ax_cv_c_float_words_bigendian=no
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --enable-ps --enable-pdf

atk 1.24.0
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu

pango 1.22.3
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu

gtk+ 2.14.7
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --with-xinput=yes --enable-debug=no --without-libjasper

librsvg 2.22.3
# ln -s seamonkey-config /usr/bin/mozilla-config
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --enable-pixbuf-loader --enable-mozilla-plugin --with-svgz


Posted on 5 Jun 2009, 10:44


No comments posted yet.