Application upgrades for Puppy2

I have upgraded heaps of libraries, now for some applications...

osmo 0.1.6
Puppy 2.x has the 'ical' package for dairy/appointments/pim, which is a Tcl/Tk application. I want to bring Puppy2 up to a par with Puppy4 and have all GTK2 apps.
I tried the latest, 0.2.6, but got an error while compiling. I looked around, found 0.1.6, that compiles ok. That version will do for now.

libgee 0.1.5
needed by vala.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu

vala 0.7.3
This is the Vala and Genie compiler. I want to compile some apps that are written in Genie, so need this.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --enable-vapigen

gtksourceview 2.4.2
Need this for some text editors, and notecase.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu

notecase 1.9.8
A most excellent outliner. Puppy 2.1.7 had version 1.5.8.
Edit Makefile, commented out this line:
HAVE_GNOME_VFS=1

mtpaint 3.31
# ./configure gtk2 --cpu=i486 GIF jpeg tiff --prefix=/usr

libgphoto2 2.4.5
Needed by sane-backends
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --with-drivers=all --with-libexif=auto

sane-backends 1.0.19
Need this for the Xsane scanner GUI application.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --enable-pnm-backend

xsane 0.996
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var

fotoxx 5.10.4
This is an image viewer, with some photo editing ability.
# export PREFIX="/usr"
# make

homebank 4.0.2
I used Turma to do a global replacement of all '.svg' in source files with '.png', as have my own (much smaller) images.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --without-ofx

gftp 2.0.19
FTP client, also does secure-FTP transfers.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu

fpm2 0.75
Figaro's Password Manager2.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
Errors in po/cs.po, so have removed it. ...hmmm, had to remove all
the .po translations before it would compile.

seamonkey 1.1.16
Get this patch from t2-project.org:
# patch -p1 < ../gtk2-x11-libs.patch
# ./configure --localstatedir=/var --prefix=/usr --host=i486-pc-linux-gnu --with-x --with-pthreads --with-system-jpeg --with-system-zlib --with-system-mng --enable-default-toolkit=gtk2 --enable-xft --enable-postscript --disable-xprint --disable-gnomevfs --disable-gnomeui --enable-crypto --enable-plugins --disable-logging --enable-strip --enable-necko-protocols=all --disable-debug --enable-mathml --enable-cookies --enable-extensions=cookie,transformiix,wallet,xmlextras,pref,spellcheck,universalchardet,permissions,typeaheadfind --disable-calendar --enable-application=suite --disable-ldap --enable-chrome-format=flat --with-distribution-id=com.puppylinux --enable-xinerama --disable-svg --disable-accessibility --disable-tests --enable-system-cairo --disable-jsd --with-system-png --enable-composer --enable-mailnews
Creating the final PET package is a bit of an art... too much to explain here.

sweep 0.9.3
Audio editor and recorder.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu

gtkam 0.1.16.1
Digital camera image reader.
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --without-bonobo --without-gnome --without-gimp

xdelta 3.0v
# make


Posted on 5 Jun 2009, 10:48


Comments:

Posted on 7 Jun 2009, 24:09 by ttuuxxx
Puppy2
Hi Barry, I love what you've compiled excellent :)
I had the error with the latest osmo also, what I did was went to the source line that was giving me the error and deleted it. Then I tried to compile it again, and It compiled without error. So the 2.14.1X version I've been working on has the latest version.
I really like the fact you recompiled the backend also. I did have a few problems with the Cairo/pango lib, It did compile for me, but I was a bit iffy on it being stable or not. Does flash work on seamonkey ? If you go to http://sourceforge.net/project/showfiles.php?group_id=199892&package_id=237250&release_id=650599
and try to download GTKhash does it crash?
It did on 2.14.1X with flash.
looking forward to your release of it and the updated packages.
ttuuxxx


Posted on 10 Jun 2009, 12:47 by BarryK
Configure mtPaint
Dmitry, the maintainer of mtPaint, was unable to post to this blog sosent me an email instead:

I see mtPaint is configured with "./configure gtk2 --cpu=i486 GIF jpeg
tiff --prefix=/usr" which is suboptimal. To get the best results
(smaller and faster binary, with less dependencies), use the "release"
configure option, like this:
"./configure release gtk2 GIF jpeg tiff --prefix=/usr"
This option enables several handpicked optimizations which are
beneficial in practice; the target CPU it uses is "i386" because as my
testing shows, the latter ones just add to binary size without
providing a noticeable speed increase.