Yet more packages for Puppy2

I mentioned some of these before as pending.

ctorrent dnh3.3.2
Commandline bittorrent client. This is needed by plinej's Pctorrent GUI application.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var

diffstat 1.47
This utility filters the output of the 'diff' utility. I don't recall what needs this -- I have probably reported about it somewhere on this blog.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu

normalize 0.7.7
Adjusts volume of audio files to a standard level. At least of one zigbert's applications need this.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --with-mad --with-audiofile

libcddb 1.3.1
Access data on a CDDB server. Needed by libcdio. This library is also needed by various other applications, such as audio CD rippers and players. This is in Puppy 412.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu

libcdio 0.80
A library for CD-ROM and CD image access. The next package, vcdimager, needs this. This is also in 412, so 218 is being brought up to par.
Note, I tried version 0.81 but it would not compile, so rolled back and 0.80 does compile.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --enable-cddb

vcdimager 0.7.23
At tool for mastering, extracting and analyzing Video CDs. Needed by zigbert's Pburn.
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu

pcmciautils 015
I have recompiled the kernel, now at 2.6.18.8, and changed it to use the new system for accessing PCMCIA. Thus the pcmciautils package is required.
# make

ndiswrapper 20090414
A module was compiled for the 2.6.18.8 kernel, so the userland executables should also be updated.
# make

ntfs-3g 2009.4.4
The driver is userland, uses fuse. I have compiled this recent version for use with the 2.6.18.8 kernel.
# ./configure --prefix=/ --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --disable-mtab

squashfs 3.3
I have brought the 2.6.18.8 kernel up to the same version of squashfs as used in the 2.6.21.7 kernel in pup 412. Compile the userland executables:
# cd squashfs-tools
# make


Posted on 9 Jun 2009, 18:18


No comments posted yet.