Retro-Puppy 218 alpha uploaded

This is the continuation of Puppy 217, and is now a remarkable blend of old and new.

Old
It has the retro 2.6.18.8 kernel, configured extremely conservatively (uniprocessor, 100Hz interrupts). It has Xorg 7.0 (or is that 7.1? -- my documentation on that seems to be wonky).
The rather long-in-the-tooth glibc 2.3.5.

New
Built with Woof, so has the latest infrastructure. That is, it works just like the very latest Puppy5 build. Identical. All of the underlying boot/shutdown scripts, all system management scripts, like the Boot Manager, Event Manager, all the latest. The desktop drive icons, theme management, install scripts, all the latest.

However, I first built with all the PET packages from 217 (actually it was the 2.17.1 release) and many of those are ancient. A fundamental problem was that the GTK library was too old (2.8.17) to compile many recent applications. So, I went through a process of upgrading packages and in some cases introducing new packages, to bring them up to at least a par with Puppy 412. I don't know if I would have done this if I realised just how long it was going to take! Anyway it's done, and documented in previous blog posts.

There is also a "new" kernel, up from 2.6.18.1 to 2.6.18.8. Actually it turns out that I had to do this. The older kernel was configured for the old PCMCIA IOCTL interface, which I have now changed to the new system (that uses the 'pcmciautils' package). I also patched the new kernel with Squashfs 3.3, for cross-compatibility with SFS files from Puppy4. Also Unionfs 2.5.1, which I have found (so far) to be very well behaved (no longer using Aufs).

I have built the live-CD with SANE scanner support built-in, again aiming to be on a par with 412.

GTK2 only
As I am bringing this retro Puppy up to a par with the latest Puppy5 builds, as also done with 412, I am focussing on GTK2 applications only. 218 has eliminated all tcl/tk and GTK1 packages, although of course they are available in the repo.

Modem special
As well as the inbuilt modem drivers (mwave, cdc-am), there are heaps of 3rd-party drivers included in the live-CD: agrsm, ess, hsfmodem, intel-536, intel-537, ltmodem, pctel, slmodem. This live-CD is a "dialup special".

Known bugs
There are a couple of bugs that I know about, that I have not yet fixed.

1. Picpuz game is broken.
2. Timezone setting does not work (tray clock will be wrong).
3. Xvesa starts at 640x480, Video Wizard does not automatically start.

If anyone would like to help out and track down those bugs, you are most welcome.

Please note that ALSA is version 1.0.14. I have not upgraded to a later version. If someone wants to have a go at compiling the latest drivers and alsa-lib and alsa-utils packages, again you're welcome. If it works and after thorough testing doesn't break anything, it could go into a future release.

The only 3rd-party wireless drivers are: rt2860, rt2870, ndiswrapper
I will rely on others to "run with the ball" on this and compile more drivers.

Package submission
Any retro-pup users are welcome to create extra PET packages and SFS files. We may also be able to host these on ibiblio.org in the 'pet_packages-2' directory. I don't know if the Ibiblio admin are going to put the brakes on this at some stage though!

A PET package compiled in retro-pup and created with 'dir2pet' should be automatically correct for inclusion. Let me know about it, after it has been tested thoroughly, and post the package database entry and anything special needed to compile it (I would like to document that on my blog, for future reference). Also post a link to the source, which I will have to host on puppylinux.com.

...actually, I don't want to get into ongoing management of Puppy2. Contact WhoDo if you would like to upload a package.

There are other places where a PET package can be hosted, such as puppylinux.ca, check with Eric on that. However, it will need to be setup with a 'Packages-puppy-2-caneri' (or whatever) file with the database entries, that the Puppy Package Manager can read. It would be good for such a repo to be setup as I have a feeling that the ibiblio people might start objecting (they have previously given warning of their hard drive that hosts all the distros is getting full).

Download from:
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/test/puppy-218/

Note, I created a .delta file from 2.17.1 to 218 live-CDs, but it was 89MB! I think that the main reason for this is the change of squashfs from version 3.1 to 3.3.


Posted on 10 Jun 2009, 18:08


Comments:

Posted on 10 Jun 2009, 18:38 by Raffy
Forum thread
Forum thread for feedback:
http://murga-linux.com/puppy/viewtopic.php?t=43432



Posted on 10 Jun 2009, 19:48 by 01micko
Working well
Thankyou Barry. 218 is working great on my Aptiva K6 400, I'll try later on my 486... we'll see! Posting from it now.


Posted on 10 Jun 2009, 20:15 by tempestuous
retro?
I don't think the use of the term "retro" is a good idea.
I see at the download location there is both pup2-218.iso and puppy-218/pup2-218-k2.6.18.1.iso
People could be excused for thinking that the 2.6.18.1 version is retro.

Really, Puppy218 is a dramatically different from Puppy 2.17, so I don't believe the term "retro" is applicable, anyway.

And if Barry (or I) get around to providing the remainder of third party drivers, I believe the 2.6.18.1 version could be dropped, because it will offer nothing different than the 2.6.18.8 version has.


Posted on 10 Jun 2009, 20:30 by 01micko
Classic Puppy?
Hmmmm.... retro.

Classic? Maybe that is a better term.


Posted on 10 Jun 2009, 21:21 by BarryK
retro 2.6.18.1
I only threw in the build with 2.6.18.1 for comparison, as I had a mysterious problem with X, as reported in a recent post. I won't be building with the 2.6.18.1 kernel again I think.

Yes, "Classic" might be a better name. Or "Vintage"?



Posted on 10 Jun 2009, 21:27 by BarryK
retro 2.6.18.1
I only threw in the build with 2.6.18.1 for comparison, as I had a mysterious problem with X, as reported in a recent post. I won't be building with the 2.6.18.1 kernel again I think.

Yes, "Classic" might be a better name. Or "Vintage"?



Posted on 10 Jun 2009, 23:00 by dogone
218 "supra"
I vote that every release that leap-frogs it's siblings (as 2.18 has leap-frogged the 3 series) be tagged with "supra", as in "supersedes". We thus have a standard term for designating leaping releases. "Retro", "Vintage" and "Classic" don't effectively convey this.

Let's be careful not to coin another vague term that serves only to clutter the Puppy lexicon.


Posted on 10 Jun 2009, 23:14 by foo
a rose by any name ..
.. 'twould be reloaded sweet. xdelta option should be an advantage going forward beyond alpha with 218 (89Mb seems about right for two years interim on the 'family' tree). Looks like woof/upup testing will pay off :)

Thank you, Barry


Posted on 10 Jun 2009, 24:36 by Sage
"Known bugs"
"There are a couple of bugs that I know about, that I have not yet fixed.
.....................
3. Xvesa starts at 640x480, Video Wizard does not automatically start. "

That is NOT a bug, it the best thing you could possibly offer. It even brings into range my old 10" kitchen monitor so I can access all my recipes again whilst working culinary magic.



Posted on 11 Jun 2009, 5:59 by puppymike
rt2860
Unfortunately no sign of module rt2860 so no network interface with my EeePC901. Also very slow booting even on the 2nd boot with a sav file.


Posted on 11 Jun 2009, 8:32 by BarryK
re rt2860sta
It should be there. Try:
# modinfo rt2860sta
See if it is actually loaded:
# lsmod
And to load it:
# modprobe rt2860sta



Posted on 12 Jun 2009, 5:31 by puppymike
rt2860 again
Hi Barry see my screen shot on the forum:
http://murga-linux.com/puppy/viewtopic.php?p=314852#314852

Unfortunately still not working for me.
Rgds Mike


Posted on 13 Jun 2009, 9:31 by Joe J
Picpuz
Barry, I sent you a pm with a fix for the error message when picpuz starts. I'll try to post a detailed fix on the forum for anyone who is interested tomorrow when I have more time. Joe


Posted on 17 Jun 2009, 13:47 by thelash
pcmciautils on 218
Re 218: Looks nice Barry. Re pcmcia - I run a frugal install of 217.1 on a usb stick inserted into a usb2 card in a pcmcia slot. I also have a full hd install of 420 and use grub on the hd to boot my frugal as this laptop doesn't boot from usb. However - I have tried similar frugal installs of pup3 and 4 series on the usb stick - they all fail because at shutdown the usbstick is turned off at the beginning of shutdown (the light goes off) so I cannot make a pupsave. I note that 218 does the same thing and assume the pcmciautils you have put in it is the same as in later series. Is it the old IOCTL interface in 217.1 that keeps the usbcard mounted at shutdown? And could this or something like it go into 218 and or later series?
Cheers.