Puppy 412 being upgraded

Awhile back I showed that Woof could be used to build from Puppy 412 PET packages, and assigned it as version '413'. Just recently I did the same for 217, then went the whole hog and upgraded lots of packages and called it '218'.

Well, I'm now giving 412 the same treatment. Going through, upgrading everything.

These are the packages that I have added or upgraded so far, compiled in the order shown:

pcre 7.8
glib 2.18.3
pixman 0.12.0
cairo 1.8.6
atk 1.24.0
pango 1.22.3
gtk+ 2.14.7
librsvg 2.22.3

libart_lgpl 2.3.20
libgnomecanvas 2.20.1.1
libgnomecups 0.2.3
intltool 0.40.5
libgnomeprint 2.18.5
icon-naming-utils 0.8.7
libgnomeprintui 2.18.3

libgee 0.1.5
vala 0.7.3

gtksourceview 2.4.2
notecase 1.9.8
mtpaint 3.31
libgphoto2 2.4.6
sane-backends 1.0.20
xsane 0.996-patched1
fotoxx 5.10.5
homebank 4.0.4
gftp 2.0.19
fpm2 0.75
seamonkey 1.1.16
libsamplerate 0.1.7
speex 1.2rc
sweep 0.9.3
gtkam 0.1.16.1

xdelta 3.0v

ayttm 0.5.0-92
medit 0.9.4
isomaster 1.3.5

perl_tiny 5.8.8
diffstat 1.47

Note, I haven't upgraded GTK to 2.16.x, decided to be a bit conservative and use the most mature release in the 2.14.x series (same as for 218).

I'll probably put in some packages from 421 next, that ttuuxxx and others have put much work into creating, such as cups and abiword.

Stay tuned, there are some exciting things happening...

Posted on 13 Jun 2009, 9:18


Comments:

Posted on 13 Jun 2009, 10:39 by dogone
412 from silver to gold
Oh man, what a very fine thing this is. 412 is already exemplary. Updates are just the ticket. Very much appreciated, Barry. Thanks so much.


Posted on 13 Jun 2009, 11:15 by ttuuxxx
Good on ya Barry :)
Nice Job Barry, 4 series really needed a new coat of paint like that :)
There has been talk about a 4 series CE version and these packages should just fit right in :)
excellent.
Thanks again
ttuuxxx



Posted on 13 Jun 2009, 18:41 by Zicozico
gfx card selection
Really appreciate the work you to on the 4.1.x series!

I'd love to see the GFX card selection included (NVIDIA, ATI, INTEL).

I recently saw that LightHouse puppy had an excellent gfx card selection menu.

And one last thing is of course, SMP!

Having these options allows me to really have one puppy 4 all pc's around here (they vary from low MHz cpu VIA's, to EEEPC's (Intel), to core2quad (NVIDIA))

Thanks,

Zicozico



Posted on 13 Jun 2009, 20:23 by 01micko
bling
So why not throw in a little bling, (Pwidgets, Rox Right Clicks, etc) and call it 4.3? It would buy plenty of time to perfect Puppy 5 IMO.

Like I said, IMO! We all have those!


Posted on 13 Jun 2009, 21:32 by ttuuxxx
updated 412
I would shoot in Icewm first then Pwidgets if space is left over and the shutdown script I made up with Hairywills tabs, and the fix menu script is well loved by many, Then if there's space streamtuner+Alsa player with flac plugins. I would like to get my hands on the updated 412, lol Rox riht clicks is nice but its very large (442kb pet) for the what your getting, almost the size of my last icewm package, with 5 themes and parcelite, jwm/icewm switch etc, look how small my lite version of gtkhash is 68kb pet, now thats worth having, it gives only sha1 and md5, but it does make it easy, great for new users and lazy users alike, lol
ttuuxxx


Posted on 13 Jun 2009, 22:09 by dogone
Let's not morph 412
It makes little sense to turn 412 into another 4.2.x. I urge restraint. 4.1.2 is Barry's baby, done in his style with his preferred apps and to his taste. Let's keep it that way. Those wanting what 4.2.x is have 4.2.x.

4.1.2 is the cornerstone of the 4 series. You don't move cornerstones!


Posted on 13 Jun 2009, 24:58 by Raffy
Graphics acceleration
MU and others have done much work in enabling the easy use of graphics acceleration in Puppy - a good example can be seen in Tipsy (puplet).

The chips in netbooks are only a handful, so perhaps they can enjoy out-of-the-box graphics acceleration with Puppy?

Thanks, Barry.


Posted on 14 Jun 2009, 4:15 by eprv
4.1.2 upgrade
I am still using 4.1.2 for its simplicity and clean desktop, this upgrade is very welcomed, please include the stardust theme, thanks.


Posted on 14 Jun 2009, 8:16 by Raffy
pxe-ready with Woof
It will also be great to use Woof in creating a PXE-ready Puppy. :)


Posted on 15 Jun 2009, 23:05 by ttuuxxx
412
Hi Barry, I also tried upgrading 4.2.1 but really is it worth it? Its basically what you did to 412, plus upgraded to glibc 2.7 from upup. It worked fine and flash 10 was stable for once on 4 series. but conky/pwidgets does make the screen rending slower even without the 2.7, I really don't like desktop icons breaking up when I move a window. Plus the extra build of icon/links and a much slower fix menus, etc. Probably would be better to use your base and take it from there, Any Idea when 4.13 will be uploaded?

I know your a Seamonkey man :) but Firefox is a real icon browser, meaning most people really enjoy it as an alternative, from puppy 2-4 Series 2.14.1X is the only version that actually runs Firefox 3.5 + flash10 properly to date. Dpup will also but Upup it has slow scrollbars. Usual issues on puppy are crashes, slowness of scrollbars, jittery window dragging, fullscreen youtube doesn't work, news reports crash the browser. And none of this happens on 2.14.1X and a official Firefox mozilla compiled release. There must be some reason why 4 series has really slow website rendering, even with the latest glib, gtk2, pango, cairo, libxext, libXcomposite, atx, gtk2, librsvg, xft, libxrender, libpthreadstubs, pixman, fontconfig, freetype, pcre, poppler, libxi, x11proto, xcbproto. Could it be because the boys did include extra kernel drivers in 2.14.1R, does Dpup also have extra kernel drivers included ? There has to be some link between the 2 iso that work right with Firefox3 series, actually Firefox 2 series was slow also on 4 series, but a lot worse with FF3 series. Any ideas on how to speed up the graphics rendering on 4 series to be on par with 2.14.1X and Dpup?

Thanks for your time Barry :)
ttuuxxx



Posted on 16 Jun 2009, 20:47 by charlie6
4.1.3 upgrade
Hi Barry,
again thank you so much times for Puppy!
Already 1 year using it (and its french version Toutou - thanks to esmourguit and others!) that brave little dog "rescued" me (I'd rather say my datas..) from a WindowsXP crash. Now I have adopted it.

About Puppy413 - frugal installed on one PC for testing - I could nice install qcad-2.0.5.0-1-i686-1js.tgz at once (as also nted-1.5.1-i486-1cf.tgz) both using the Slackware 12.2 archives.

I have tried the same install on Puppy412 frugal with less less success:
NtEd: clicking on it opens the XArchiver - extracting all under / results in an installation which seems to work OK (I cannot figure whether correct or incorrect install as I am rather newbie - Aaargh...where can I learn about Linux...in a more methodic way than doing cut and try?)

QCad: XArchive opens the file and without ending the process - I have to stop the process otherwise it would'nt end even after a few minutes.

I wonder why such difference between 412 and its-upgrade-413?
I read in the doc that Puppy3.xx was based on Slackware (I really do not know as yet what that means...) and further 4 versions were not; and that 413 was based on WOOF (searched to learn a bit more about woof ...I am still on way to).

I'm managing to get a 'one-installation-of-Puppy whit tools I'm using the most' instead of 2 or 3 different installations of different Puppy versions.

I just wonder if the future 412 upgrade will allow to keep the ease of install of 413; or if some pet installation would not longer be possible?

Anyway looking forward to welcome future Puppy 412 issue.

Cheers
Charlie



Posted on 17 Jun 2009, 2:28 by ttuuxxx
412
Hi charlie6, Xarchive also takes its time when opening tar.bz2 files, like Seamonkey sources can take about 30mins+, I made a pet package for puppy 4.2 series that replaces xarchive with xarchiver, if you install it, it should work better for you.
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xarchiver-0.5.2-PupZip-v5.pet
If it doesn't you can always just uninstall it using the package manager.

Series 3 was slackware compatible, Series 4 moved away from that, you can still use some slackware packages, but 4 series doesn't use gtk-1.2 or glib-1.2, If you open the package manager and select series 3, then install something like gtk-1.2 and glib-1.2, that would help.
Installing slackware on 4 series isn't 100% perfect and the best way to install slack packages, would be extract the pakage into a folder, say in /root and you named the folder, gimp, now leave the folder and open a command prompt and type
dir2pet /root/gimp
and follow the instructions, then run the pet package you just made, it should install and tell you if your missing anything, if you are I could look in series 3 for it. But take note you can break your puppy really bad, say if you changed glibc or other system backends. I personally would use bigbass's Slacker puppy or Series 3.0.1,or request a package in the forum, most will build you a package if need be.

Woof is a set of scripts that Barry the Great made, basically you run the scripts and it downloads hundreds of packages and within a couple of hours you have a new Debian/Ubuntu/Slackware combined base of puppy Linux, that will run Slackware packages, or Debian, or Ubuntu depending on which you choose to build.
The main focus of Series 5 Barry decided will be Ubuntu, I like the Debian better, but that's my problem,lol Also others like Slackware better, That would be my second choice :) lol.

Maybe do a forum search for Slackware,
have fun
ttuuxxx