ValaIDE 0.5 does not compile in Puppy4

Nicolas has created this IDE for Vala and Genie code development. I reported a problem compiling with GTK 2.14.x, and Nicolas has provided a patch:

# patch -p0 < ../gtk-2.14.patch
# export PREFIX='/usr'

# ./waf configure
...I am doing this in 413, and some things are missing. I grabbed Ubuntu Intrepid packages 'docbook-to-man', 'gnome-doc-utils', 'dbus' and 'dbus-glib'. Er, the first pkg installs an executable 'docbook-to-man', whereas ValaIDE wants 'docbook2man' ...hmm. I'm not online, can't do a search. Ah, it's in Ubuntu package 'docbook-utils'.
Still failure. I had to edit 'wscript' to accept GTK version 2.14.x.

This compiles it...
# ./waf

'shared-mime-info' pkg is needed to install, I grabbed a Ubuntu Intrepid pkg.
# ./waf install
...install stops with the error message that this file does not exist:
* installing _build_/default/data/valide.desktop as /usr/share/applications/valide.desktop
I created an empty file, then the install gets further, but still get an error:
libvalide/project-manager.vala:240.19-240.48: error: The name `row_is_expanded' does not exist in the context of `Gtk.TreeView'
libvalide/project-manager.vala:187.11-187.40: error: The name `row_is_expanded' does not exist in the context of `Gtk.TreeView'

...it seems that "./waf install" step still has more compiling to do, and is failing.
Also get this error:
File '/mnt/sda3/sources/sources251/0-texteditor-vala-nicolas/valide-0.5.0/_build_/default/libvalide/valide-0.0.h' does not exist

Well, that's the end of that.

Forum thread with the 'gtk-2.14.patch' file:
http://murga-linux.com/puppy/viewtopic.php?t=39560&start=315


Posted on 18 Jun 2009, 10:29


No comments posted yet.