Grumble, grumble, 414 oversights

I was going to drive home this morning, but after reading the first feedback on 414, I realised some major things wrong.

Click on png in rox
That is supposed to launch MU's Pictureviewer, but I found that I have left out an upgraded 'poppler' library that it needs. I have now added these two pkgs:

poppler-0.10.7-pup4.pet
poppler_DEV-0.10.7-pup4.pet

Zigbert's apps old
Zigbert reported lots of his apps not upgraded. They should have been. I found the problem. These are the ones that are now upgraded:

Pmusic, Pburn, Pfilesearch, Pfind, Pbackup.

...any others will have to be in the next build.

I also found Pwireless was old, upgraded.

Printing
I did say that you will have to fix cups_shell to get printing to work, but already feedback that it doesn't without any attempt to fix cups_shell. Ok, let's see... here is a modified /usr/sbin/cups_shell:

#!/bin/sh

#Barry Kauler, for Puppy Linux v2.17. LGPL.
#BK updated for 3.01
#v3.94 14 dec 2007 BK updated.
#v3.98 bugfix. w462 small mods.
#w471 add 'cupsview'.
#w480 bugfix if still using old cups.

USEBROWSER="defaultbrowser"
[ -f /usr/bin/netsurf-barewindow ] && USEBROWSER="netsurf-barewindow"
[ -f /usr/local/bin/bareview ] && USEBROWSER="bareview" #from gtkmoz pkg.
[ -f /usr/local/bin/cupsview ] && USEBROWSER="cupsview" #w471 from gtkmoz pkg.

#v3.98 'lpr' is a script in cups package, comment this out...
##v2.17.1 PDQ print system has lpr symlink to /usr/bin/pdq, set in /usr/sbin/printerwizard.sh,
##so may have to change it back...
#rm -f /usr/bin/lpr
#ln -s lpr-cups /usr/bin/lpr

#v2.20 warning the defaultbarehtmlviewer must support css.

Xdialog --yesno "Do you want to add a new printer?" 0 0
if [ $? -ne 0 ];then
#is cupsd running?...
if [ "`pidof cupsd`" = "" ];then
#[ -f /etc/rc.d/rc.cups ] && /etc/rc.d/rc.cups start
#[ -f /etc/init.d/cups ] && /etc/init.d/cups start
/etc/init.d/cups start
fi
#exec defaultbarehtmlviewer http://localhost:631/
exec $USEBROWSER http://localhost:631/
fi

xmessage -bg "medium purple" -title "CUPS Web Interface Help" -center "
Your default browser should have opened (or will open after 3-30 seconds) with the CUPS
web interface. Here you can add and configure your printer.

IMPORTANT: If asked for a username and password, enter 'root' and 'woofwoof'.

Click on 'Manage Printers', then 'Add Printer'. Enter a name for your printer, e.g.
HL1030. The 'Location' and 'Description' fields can be left blank. Click 'Continue'.

The steps after that should be straightforward, and hopefully you will find a printer
driver that works for you. Finally you should see the message:
'Printer HL1030 has been added successfully.'

- If no suitable printer is found, check www.linuxprinting.org for a .ppd file for your
printer. When you have downloaded it, just copy it to the /usr/share/ppd directory
and run this program again (from the System menu). Note, there is also a PET package,
'hpijs-1.7' with more Hewlett Packard printer drivers.

Click on 'Printers', 'Configure Printer' to change 'Page Size' (if needed) and 'Resolution'
(600 DPI is good). Click 'Continue', then 'Printers' again. The 'Printer State' should be
'idle, accepting jobs.'

Finally, click 'Print Test Page' to see if your printer works." &

#killall cupsd
/etc/init.d/cups stop

mkdir -p /usr/share/cups/model/gutenprint/5.2
mkdir -p /usr/share/ppd/gutenprint/5.2

#w480, need to run cups-genppd if old cups...
CUPSVERSION=""
[ "`which cups-config`" != "" ] && CUPSVERSION="`cups-config --version`"
if [ "$CUPSVERSION" = "1.1.23" ];then
[ "`which cups-genppd.5.0`" != "" ] && cups-genppd.5.0
[ "`which cups-genppd.5.2`" != "" ] && cups-genppd.5.2
fi

sync

#/usr/sbin/cupsd
/etc/init.d/cups start
sleep 1

#mv /usr/share/cups/model/gutenprint/5.0/*.gz /usr/share/cups/model/gutenprint/5.0/C/

#defaultbarehtmlviewer http://localhost:631/
$USEBROWSER http://localhost:631/


#rm -rf /usr/share/cups/model/gutenprint/5.0/C
if [ "$CUPSVERSION" = "1.1.23" ];then #w480
rm -rf /usr/share/cups/model/gutenprint/5.2/*
rm -rf /usr/share/ppd/gutenprint/5.2/*
fi


leafpad
Is not there anymore, replaced by nicoedit, but some scripts explicitly call leafpad. There is supposed to be a symlink, but it isn't there, now fixed I think.

415 upload
I wannah go home! I was all set to drive home this morning. Now I have to fix these most urgent bugs, rebuild, do some testing, then upload. Oh well. It will take 4-5 hours. I'm going to bump the version number to 415, to avoid confusion. Of course I'm doing all this fixing in a hurry, hope I don't do something else dumb.


Posted on 24 Jun 2009, 10:26


Comments:

Posted on 24 Jun 2009, 10:36 by BarryK
414 printing
Note, I noticed a symlink /usr/share/cups/model/foomatic-ppds got deleted by the Woof build scripts. Could you guys who know all about printing check that one out, see if it breaks anything? The only reason it would get deleted is if it didn't point to anything.



Posted on 24 Jun 2009, 11:49 by wolf_pup
updated woof?
barry, when will the updated woof appear?


Posted on 24 Jun 2009, 13:51 by BarryK
415 alpha
See next blog post:

http://puppylinux.com/blog/?viewDetailed=00838



Posted on 25 Jun 2009, 10:02 by BarryK
Re: updated Woof
The latest Woof was also uploaded to the test/415alpha directory at ibiblio.