415: Cups, Gutenprint upgraded

cups 1.1.23-patched1
Not a version upgrade, just a patch provided by kirk to enable a print job to be cancelled in the web interface.

gutenprint 5.2.3.99.1
Puppy 4.1.2 has version 5.0.1. This upgrade of course supports more printers, but one thing I don't like is the move to XML format for the printer definition files (see /usr/share/gutenprint/5.2/xml/escp2/model) -- this is a very inefficient way to store large amounts of data, and results in a much bigger PET package.

Anyway, I have built the latest "416-alpha-preliminary" and printing works. I tested printing to my Brother HL2040 laser, which has a foomatic driver. I also tested on the latest acquisition from that opportunity shop, an old 64MB PC with Epson Stylus C41SX printer, and that works too, with a gutenprint driver.

Working with the 64MB PC, I am finding usability issues. There was the 'depmod' thing, solved, now I'm going to work on an improvement to swap file creation -- will do that Sunday/Monday.

I'll try and target 416alpha for upload in about a week from now.


Posted on 3 Jul 2009, 20:30


No comments posted yet.