423: JWM revision 456

I have compiled Joe's latest from CVS, revision 456. This is dated 26th March 2009 and Joe has not worked on it since then.

We had a problem with this version in Upup, which is why I have been using Patriot's 2.0.1pb in Ppup builds. The problem was icons not displaying, which appears to happen when 24-bit color depth is chosen -- though I have not personally confirmed this.

Anyway, I thought perhaps it might just be a problem in Upup, so I have compiled rev. 456 in Ppup 423 (4.3beta1) and will test it on a range of PCs. So far just tried it on my laptop, and I get the icons ok in 16-bit and 24-bit depths.


Posted on 17 Aug 2009, 19:05


Comments:

Posted on 17 Aug 2009, 19:56 by charlie6
ppa423 Grub: do not create menu.lst
Hi,
managing to install ppa423 frugall on /dev/sda3 ext3 partition, from live-cd:

when running Grub bootloader config from live-cd there is'nt any /tmp/Newgrubtext.lst, nor menu.lst created in /boot/grub

# pwd

/mnt/sda3
# ls
boot lost+found pp4a-423.sfs pp4asave-423_1.2fs puppy423
# cd puppy423
# ls
ATAHD initrd.gz pp4a-423.sfs vmlinuz
# cd ..
# ls
boot lost+found pp4a-423.sfs pp4asave-423_1.2fs puppy423
# cd boot
# ls
grub
# cd grub
# ls
e2fs_stage1_5 jfs_stage1_5 stage2 xfs_stage1_5
fat_stage1_5 minix_stage1_5 stage2_eltorito
ffs_stage1_5 reiserfs_stage1_5 ufs2_stage1_5
iso9660_stage1_5 stage1 vstafs_stage1_5
#


I'll get to try with a puppy4.1.2 live-cd.

cheers
charlie


Posted on 17 Aug 2009, 19:56 by charlie6
ppa423 Grub: do not create menu.lst
Hi,
managing to install ppa423 frugall on /dev/sda3 ext3 partition, from live-cd:

when running Grub bootloader config from live-cd there is'nt any /tmp/Newgrubtext.lst, nor menu.lst created in /boot/grub

# pwd

/mnt/sda3
# ls
boot lost+found pp4a-423.sfs pp4asave-423_1.2fs puppy423
# cd puppy423
# ls
ATAHD initrd.gz pp4a-423.sfs vmlinuz
# cd ..
# ls
boot lost+found pp4a-423.sfs pp4asave-423_1.2fs puppy423
# cd boot
# ls
grub
# cd grub
# ls
e2fs_stage1_5 jfs_stage1_5 stage2 xfs_stage1_5
fat_stage1_5 minix_stage1_5 stage2_eltorito
ffs_stage1_5 reiserfs_stage1_5 ufs2_stage1_5
iso9660_stage1_5 stage1 vstafs_stage1_5
#


I'll get to try with a puppy4.1.2 live-cd.

cheers
charlie


Posted on 18 Aug 2009, 12:52 by ttuuxxx
jwm
Hi Barry I've used JWM-456 in the puppies 4.2 no bling release and 2.14X and never had that issue, Its always worked perfect, The only issue I had was JWM config utilities in 2.14X could be other reasons why they weren't working right, but I managed to get them working after messing around with them.
ttuuxxx


Posted on 19 Aug 2009, 2:33 by foo
456
Have used the jwm-456-i386 dotpet and it seems to work well in all that I've tested but uP476 - in ppa-423 it allows a drag-resize from the top border/header (should make panzerpuppy and some few others happy :) )


Posted on 19 Aug 2009, 17:36 by 01micko
jwm456
Awhile back I made a package for Slaxer_pup using an app by amigo named src2pkg. It compiles and packages a .tgz slackware type package. I installed it directly into ppa-423 and it seems to work fine with 24bit colour depth and the menu items. I vote yes to jwm456!


Posted on 19 Aug 2009, 17:39 by 01micko
woops
Um, I was one of those who complained about the upup 476 issue with 24 bit depth. Forgot to remind you of that. This is on the exact same system.

Cheers