Quirky version 0.0.1

The live-CD ISO file is 90.36MB and available from here:

http://distro.ibiblio.org/pub/linux/distributions/quirky/quirky-001/

There is also a README file:

http://distro.ibiblio.org/pub/linux/distributions/quirky/quirky-001/001-readme.htm

...which explains that this release only has a "quirkiness factor" of one.

I have only just uploaded it, it hasn't got through to the mirrors yet.


Posted on 8 Dec 2009, 8:55


Comments:

Posted on 8 Dec 2009, 11:31 by Grumpywolfe13
Like the dog
Hi Barry I downloaded and tried it just to see what you were trying to achieve. I have put together a little thing I call a control panel that may fit in with your tool bar. http://mywolfe.googlecode.com/files/ControlPanel-003.pet

I know that you could do it in a day but I am learning.


Posted on 8 Dec 2009, 12:42 by lobster
Quirks
Istalled and ran OK for me

the Quirk logo did not resize like the other rox menubar icons
and Imagination did not run from the graphic menu

The clean desktop works well ad the analogue clock is nice


Posted on 8 Dec 2009, 13:36 by Ramachandran
Quirky
I have installed full hard disk (Ext3 partition), and thank you very much. I would be very grateful to if you could provide modem driver - Conexant. I know your priority and limitation in this regard. Kindly excuse me for troubling you. I know your valuable time cannot be spared for this. Without Dial up, my Quirky will be "Fish out of water" as I have Dial up connection at my home.


Posted on 8 Dec 2009, 15:49 by James c
Quirky
Playing with Quirky running live.This is one neat little quirky Puppy......the new desktop should work great on small screen netbooks.Seems really quick as well.


Posted on 8 Dec 2009, 17:06 by Ramachandran
Quiry
I Gpart partition tool, no Ext4 format. Is it Bug or default settings ?. Due to this limitation, I have forced into install Ext3 partition. I have install Google Chrome and working fine. Java runtime is not working properly in SM. While opening Java enabled site, SM hangs.


Posted on 8 Dec 2009, 19:25 by Ramachandran
Quirky
In my Full Hard Disk ( Dual Boot - Ext3 Partition Sd10), I have observed that "PowerOff" and Reboot function is not working properly. Sometimes, its works. Otherwise, when apply "PowerOff" , the screens goes blank and comes usual desktop. Due to this problem, I have to apply hard/force shutdown.


Posted on 9 Dec 2009, 4:40 by JustGreg
Quirky & 2GoPC
I installed Quirky on USB stick and tried it on 2GoPC. Quirky started and ran, but, did not correctly apply 915GM chip set fix. I had to copy resolutionfix from a Puppy 4.30 installation. I am working to get the wireless networking to run. It does look nice.


Posted on 9 Dec 2009, 7:24 by BarryK
Re: 2gopc
JustGreg,
Do you mean the '915resolution' application?
Um yes, I compiled it in T2 I think, but the official version is not as good as our patched version. ...at least, that's what I remember, I'll check it out.



Posted on 9 Dec 2009, 7:44 by svgt
Long first time startup
I started the Quirky system after a successful hdd full installation. The startup line came on. There was a period of about 5 minutes till the first messages appeared. (700MHz 256MB)

The next times normal speeds.


Posted on 10 Dec 2009, 8:45 by X
Mirrors pointed at puppy not quirky.
So only slow original site available 10kb/sec


Posted on 14 Dec 2009, 15:13 by rothua
Error 13 on quirky boot
usual click unpack quirky.iso to a directory then grub boot gives first of without anything else Error 13.


Posted on 18 Dec 2009, 4:00 by ttuuxxx
Quirky Devx
devx doesn't work when building geany.

# ./autogen.sh

**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`./autogen.sh' command line.

Processing configure.ac
/usr/bin/glib-gettextize: line 139: cd: /usr/share/glib-2.0/gettext: No such file or directory
gettext source directory '/usr/share/glib-2.0/gettext' doesn't exist
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
libtoolize: `AC_PROG_RANLIB' is rendered obsolete by `LT_INIT'
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of AM_PATH_AUDIOFILE
/usr/share/aclocal/audiofile.m4:12: run info '(automake)Extending aclocal'
/usr/share/aclocal/audiofile.m4:12: or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
Running ./configure ...
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: in `/root/my-documents/geany-0.18':
configure: error: C compiler cannot create executables



/usr/lib/gcc/i486-t2-linux-gnu/4.3.4/../../../../i486-t2-linux-gnu/bin/ld: cannot find -lgcc_s
collect2: ld returned 1 exit status
configure:3474: $? = 1
configure:3511: result:
configure: failed program was:
| /* confdefs.h */

ttuuxxx



Posted on 18 Dec 2009, 8:40 by BarryK
Quirky devx
I got Geany out of SVN, as per instructions here:
http://www.geany.org/Download/SVN

I then ran:
# ./autogen.sh
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu
# make

...it's compiling right now.

However, I'm using the '002' devx, which has a couple of bug fixes. 002 will be uploaded in a couple of days.

Yes, Geany out of SVN is very interesting as it has support for Genie syntax highlighting.
...hmmm, if I put it into Quirky, I first need to examine ways of reducing the size elsewhere.



Posted on 18 Dec 2009, 12:25 by ttuuxxx
DevX
had a look at /usr/lib/gcc/i486-t2-linux-gnu/4.3.4/include/ and it didn't have the normal C++ directory that usually contains most of Gcc deps, any reason why the C++ folder is missing?
also couldn't compile the geany svn either, same error
I'm trying to compile live like I always do, Basically just convert the devx.sfs to a pet package and install it, like I've done for years with puppy. Well looking forward to the second devx.
ttuuxxx


Posted on 18 Dec 2009, 15:37 by BarryK
C++
ttuuxxx,
I just looked in the path you specified, I don't have any C++ folder. I also looked in Upup, it dosn't have any C++ folder either.

The 002 devx works fine. The 001 devx worked ok for me also, but not for all packages as it was a little bit broken.