Swfdec-mozilla Flash plugin

I have uploaded liboil 0.3.16, libsoup 2.28.2, libgpg-error 1.7, libgcrypt 1.4.5, gnutls 2.8.5, swfdec 0.6.8 (patched) and swfdec-mozilla 0.6.0 sources:

http://bkhome.org/sources/alphabetical/

To compile the Swfdec player with least dependencies, build as follows:

liboil 0.3.16
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu
# make
# new2dir make install

libsoup-2.28.2
disable ssl, compile static lib only...
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --enable-debug=no --disable-shared --enable-static --without-gnome --disable-ssl
# make
# new2dir make install

swfdec 0.6.8-patched
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --with-audio=alsa --disable-gstreamer --enable-ffmpeg --disable-static --enable-mad
# make
# new2dir make install

swfdec-mozilla 0.6.0
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --with-plugin-dir=/usr/lib/mozilla/plugins --disable-static
# make
# new2dir make install

Libsoup is compiled statically into Swfdec as it is somewhat crippled without the SSL support. I could have compiled liboil statically, in fact I could even have compiled Swfdec statically into Swfdec-mozilla for the absolute smallest size.

Gstreamer option
There is also the option of abandoning Xine and going over totally to Gstreamer. The main problem with that is Gstreamer does not want to compile with external ffmpeg (well, perhaps that could be hacked, but the Gstreamer developers very strongly recommend to use their internal ffmpeg). Puppy has some apps that rely on the external ffmpeg.
It would be interesting to get Gstreamer to compile with external ffmpeg and see how well it works. Swfdec can be compiled against Gstreamer instead of ffmpeg.

Oh yes, I should report on that. I did compile Swfdec against Gstreamer, and some videos at youtube.com just were a black window -- no video or sound.
On the otherhand, for Swfdec 0.6.8 with ffmpeg, so far I've tested about a dozen videos at youtube.com and they all work.


Posted on 31 Dec 2009, 8:48


Comments:

Posted on 1 Jan 2010, 20:33 by ttuuxxx
gstreamer ffmpeg plugin
Hi Barry is this what your looking for ?
http://gstreamer.freedesktop.org/modules/gst-ffmpeg.html
not much info on it.

"GStreamer FFmpeg plug-in contains one plugin with a set of elements
using the FFmpeg library code. It contains most popular decoders as
well as very fast colorspace conversion elements."


Posted on 1 Jan 2010, 20:43 by ttuuxxx
Better yet found a version with patches
Barry this version of Gstreamer comes with 2 ffmpeg patches so you can compile with a external ffmpeg :) :) :) and its the latest version
http://fr.rpmfind.net/linux/Mandrake/2010.0/SRPMS/main/release/gstreamer0.10-ffmpeg-0.10.9-1mdv2010.0.src.rpm
ttuuxxx


Posted on 1 Jan 2010, 21:20 by BarryK
Gstreamer and ffmpeg
ttuuxxx,
Thanks for finding the patched gstreamer-ffmpeg.