lameSMBxplorer 0.1.1a

Patriot has developed a new Samba shares browser, that looks like it can replace HairyWill's Pnethood. Forum thread:

I have made it into a PET package and placed at my Quirky repository:

Of course, Patriot already had a PET package, but I updated it with the 'pet.specs' file and a list of dependencies. Which are:


One difference from Pnethood is that lameSMBxplorer does not use 'mount.cifs' from the 'mountcifs' package -- or does it?

A note about the database entry in 'pet.specs', this is it for lamesmbxplorer:

lamesmbxplorer-0.1.1a|lamesmbxplorer|0.1.1a||Network|76K|pet_packages-quirky||+gtkdialog3,+nbtscan,+samba_client|connect to samba shares|||official|

...I'm planning to make a small change, allow the subdirectory field to be empty. I have put "pet_packages-quirky" in it, but that of course is only relevant when it is at my repo.
I will now allow the field to be blank:

lamesmbxplorer-0.1.1a|lamesmbxplorer|0.1.1a||Network|76K|||+gtkdialog3,+nbtscan,+samba_client|connect to samba shares|||official|

...and the meaning of the empty field is that the package is located in the default location on whatever repo it is held.

I intend to update the package manager to recognise an empty path field to have that meaning.

Posted on 8 Jan 2010, 15:38

No comments posted yet.