Xorg server, nv, updated

I decided to update the 'xorg-server' and 'xf86-video-nv' packages in Quirky. As Quirky is cut-down, I thought that I would probably need the 'mesa' package, so I ran the Puppy Package Manager and installed it from the T2 binary repository.

Puppy Package Manager fixed for .tar.bz2 packages
PPM also stated that 'mesa' needed two dependencies, 'dri2proto' and 'sysfiles'. I installed the former only. 'sysfiles' is core structural files that are already in Puppy, so to avoid this issue in the future, I added "sysfiles" to the 'PKG_NAME_IGNORE' variable in file /root/.packages/PKGS_MANAGEMENT (this is done in Woof, so will be in all puppy builds).

But then I discovered that PPM has a bug, does not actually install any files. I edited /usr/local/petget/installpkg.sh and fixed so that .tar.bz2 packages do get installed.

I ended up installing these T2 binary pkgs:

mesa
dri2proto
glproto


I have the 'devx' and the 2.6.31.5 kernel source SFS files loaded, although I don't know if the latter is needed.

xorg-xserver 1.7.3
Quirky is supposed to be as cutdown as is reasonable... so I have taken out the XvMC (Xv Motion Control) support, as my understanding is that not all Xorg drivers support it. DRI2 is probably in the same boat, but I have left that in. It is a bit of a concern taking out too much, as then the commercial Nvidia drivers might not compile -- although one of my reasons for upgrading is to see if the latest 'nv' driver will do the job, so the commercial Nvidia drivers won't be needed. Anyway, giving this a go...

# ./configure --prefix=/usr/X11R7 --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --disable-dmx --disable-xvfb --disable-xephyr --disable-config-hal --disable-xnest --enable-kdrive --enable-xsdl --disable-xvmc
# make
# new2dir make install


...very interesting, I enabled the 'Xsdl' kdrive server. What is this? There is no documentation in the package. Ah, the Xorg 7.5 release notes have this:

Xsdl server
The experimental Xsdl server has never been finished or maintained, and will be removed in future X server releases.


...so much for that! There is not much left in the 'kdrive' category. For 7.5, everything has been removed, except for the Xsdl and Xfbdev servers.

xf86-video-nv 2.1.16
The version compiled in T2 and hence in Quirky up until 003 is 2.1.15. So, we shall see if this one makes any difference...

# ./configure --prefix=/usr/X11R7 --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --with-xserver-source=../xorg-server-1.7.3
# make
# new2dir make install


These upgrades will be in Quirky 004. The bugfixes for Woof will be uploaded soon.


Posted on 11 Jan 2010, 19:58


Comments:

Posted on 11 Jan 2010, 20:34 by lobster
nvidia
It will be interesting if nvidia works for me on Q004 (Quirky 004) I have had this ps2 problem and change to using a USB mouse.

Both Dpup and Quirky are not yet quite in a position to replace 4.3.1 (for me) I like to be cutting edge and use experimental Puppys but need the base of multimedia (ogle in Quirky) means I would need to add VLC (or similar)

Looking forward to te next Quirky :)



Posted on 11 Jan 2010, 24:47 by Ramachandran
Quirky003
As I unable to install Quirky 003 in my PC. I have already pointed out my problem in Quirky 003 feedback. I am looking forward clean Quirky004.ISO.


Posted on 12 Jan 2010, 4:00 by happypuppy
Xorg, nv and NVIDIA cards
The latest version of X Server is 1.7.4

And 'nouveau' is a far better Open Source driver for nvidia cards than 'nv'.




Posted on 12 Jan 2010, 8:05 by BarryK
Nouveau driver
happypuppy,
Thanks for that info. I have downloaded latest xorg-server (1.7.4), also I'm getting the nouveau driver out of git, from here:

http://cgit.freedesktop.org/nouveau/xf86-video-nouveau/

By this command:

# git clone git://anongit.freedesktop.org/nouveau/xf86-video-nouveau

Hmmm, the Xorg Wizard is going to need some mechanism to select between 'nv' and 'nouveau' when you test the video.

Note, I got the latest xorg-server from here:

http://xorg.freedesktop.org/releases/individual/



Posted on 12 Jan 2010, 8:41 by happypuppy
ATI drivers
Make sure you compile the latest ATI driver as well (there are lots of bugfixes and improvements in the latest version)

The three most important and most popular open source video drivers for Linux at the moment are xf86-video-ati , xf86-video-intel and nouveau.



Posted on 12 Jan 2010, 8:44 by happypuppy
...and don't forget ALSA
And don't forget ALSA :)

ALSA has been updated to 1.0.22.1



Posted on 12 Jan 2010, 9:13 by Leon
ATI
xorg.conf informations

Puppy 4.3.1
Identifier "Card0"
Driver "ati" #card0driver
VendorName "ATI Technologies Inc"
BoardName "RV280 [Radeon 9200 SE]"

Quirky 003
Identifier "Card0"
Driver "radeon" #card0driver
VendorName "Unknown Vendor"
BoardName "Unknown Board"

Progress from Quirky 002
- xvidtune works

Problems
- black background behind the menu icons
- much slower video playback compared to Puppy 4.3.1 on the same computer


Posted on 12 Jan 2010, 9:40 by Leon
Boot problem still present
The same problem as with Quirky 002. When using a 'pkeys=slovene' parameter in a grub4dos menu.lst file this messages are shown on the screen during the boot process:

Loading 'slovene' keyboard layout... failed
Dumping last lines of kernel log...
loadkeymap: /dev/tty0: No such file or directory
loadfont: /dev/tty0: No such file or directory
<6>TCP_cubic registered
<6>NET: Registered protocol family 17
<6>Using IPI No-Shortcut mode
<6>Freeing unused kernel memory: 340 k freed
Pausing for 60 seconds...

It is interesting that the 'slovene' keyboard layout, rox filenames display on vfat partitions and all sl_SI locale settings works properly.