Quirky "multimedia special" coming

I have built a Quirky that "plays everything", which will be uploaded as 005, real soon.

I explored radical options in Quirky 003, using Swfdec as the Flash browser plugin, 'ffplay' as the media player, mozplugger to launch appropriate players for embedded browser audio or video, and Ogle to play DVD movies.

Ffmpeg
Yesterday I started again, from scratch. I got ffmpeg out of version-control, dated 2010-01-16. I compiled dependencies opencore-amr 0.1.2 and x264 20091230.

I then went the usual route, compiled xine-lib and gxine, but it was disappointing, some test files did not play properly.

Mplayer
So, I got mplayer out of version-control, dated 2010-01-17, and went through a very tortured process of getting it to compile, with the external ffmpeg dependency. I patched the source, and I will upload 'mplayer-2010-01-17-patched.tar.gz' to my source repo soon -- it also has a special script to do the final link step that builds the 'mplayer' executable. I have also left the source pre-configured so you just type 'make' to compile.

Mplayerplug-in
I compiled mplayerplug-in 20100117 to handle browser embedded content.

Adobe Flash Player
To top it all off, I put in the official Adobe Flash browser plugin, version 9.0.124.0 (more stable than the 9.0.48.0 used in Puppy 431).

Ogle
I built mplayer without DVD playing capability, as I have never been able to get that working right (mplayer can still play VCDs). I have left in Ogle specifically to fill that gap.

Conclusion
The end result is quite remarkable. This combo plays everything I have thrown at it, and plays everything properly. I've got a Lindows RealMedia video that played with garbled sound, now plays nicely. The 'sunrise.wmv' that I had trouble with gaps in the sound, now no gaps.

Beautiful! the iso is 91MB.

Note, one little hiccup is that with some files, mplayer displays an error window that a certain codec is missing, yet the video plays ok. What is happening is that mplayer is thinking a certain codec is required, however ffmpeg has the video and audio capability to play it. I would like to figure out how to suppress that error message window.


Posted on 18 Jan 2010, 14:32


Comments:

Posted on 18 Jan 2010, 15:13 by cthisbear
Mr Radical
" radical options in Quirky 003 "

I suggest no more Red Wine donations for BK.

Good on you Barry....Chris.


Posted on 18 Jan 2010, 15:17 by Terryphi
Adobe Flash Plugin
Why not use Adobe Flash plugin 10.0.42.34? It works perfectly for me in Quirky/Puppy.

It is preferable to make provision for version upgrade too. The adobe .deb installs libflashplayer.so in /usr/lib/adobe-flashplugin. Create a symlink to it from /usr/lib/mozilla/plugins/libflashplayer.so and then users can easily upgrade to later versions simply by downloading and installing the .deb from Adobe.


Posted on 18 Jan 2010, 15:52 by disciple
suppress the errors
You might be able to suppress the error messages by starting with -really-quiet
IIRC there is an equivalent line you could put in the config files.


Posted on 18 Jan 2010, 16:35 by Tony
Mplayer
Hi Barry, I think it's great you doing a multimedia version. Please could I ask that you consider SMPlayer as it is so configurable,
http://smplayer.sourceforge.net/

Things like Multiple speed playback. You can play at 2X, 4X... and even in slow motion.

It remembers the settings of all files you play
You can easily configure every option of SMPlayer by using a nice preferences dialog.

And loads of other really useful things.
Many thanks
Tony


Posted on 18 Jan 2010, 17:57 by BarryK
Re Smplayer
Tony,
no, Smplayer needs Qt4 libraries, which Puppy/Quirky doesn't have as they are too big.



Posted on 18 Jan 2010, 18:44 by BarryK
Flashplayer 10
Ok, Woof now has /usr/lib/adobe-flashplugin as a symlink to /usr/lib/mozilla/plugins. When the Adobe Flash .deb is installed, the file libflashplayer.so gets installed into /usr/lib/mozilla/plugins.

Yeah, as this is going to be a "multimedia special", I have upgraded to Flashplayer 10.0.42.34. I've been testing it, stable so far.



Posted on 18 Jan 2010, 19:51 by panzerpuppy
Multimedia Quirky
Wow! MPlayer, ffmpeg SVN and Flash 10 :D

Can't wait to take this puppy for a walk.



Posted on 18 Jan 2010, 23:05 by technosaurus
flash deps
Besides the extra size Flash10 does have some extra dependencies.

As long as you are using gecko based browsers that have nss and nspr, Flash10 should be fine using the symlinks in /usr/lib...(like you already have set up) it only adversely affects remastering where people replace seamonkey with opera, midori, etc...those symlinks break.

Compiling those separately and compiling mozilla browsers with --with-system-nspr and --with-system-nss etc... will prevent this and not add size


Posted on 18 Jan 2010, 23:59 by ttuuxxx
Gnome Mplayer
Hi Barry maybe next time try Gnome Mplayer, or Gmplayer, The package I made for upup played dvd's in upuphttp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-5/Gnome-Mplayer-29305-i486-uj.pet
ttuuxxx


Posted on 19 Jan 2010, 8:45 by BarryK
Mplayer and DVDs
ttuuxxx,
The problem that I always had with mplayer was I couldn't get the menu navigation to work. Yes, it's fine getting mplayer (or gmplayer) to play a DVD, but not the initial selection menu.

If mplayer developers have fixed that problem, then good, I'll take another look at it.

Quirky has Gmplayer, that comes with the mplayer package.



Posted on 19 Jan 2010, 8:53 by BarryK
Mplayer SM deps
technosaurus,
Yes, /usr/lib/seamonkey is in the library search path in Woof builds, so libflashplayer.so finds everything:

# ldd /usr/lib/mozilla/plugins/libflashplayer.so


linux-gate.so.1 => (0xffffe000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb6b52000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb6b3b000)
libX11.so.6 => /usr/X11R7/lib/libX11.so.6 (0xb6a3e000)
libXext.so.6 => /usr/X11R7/lib/libXext.so.6 (0xb6a31000)
libXt.so.6 => /usr/X11R7/lib/libXt.so.6 (0xb69ed000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6988000)
libfontconfig.so.1 => /usr/X11R7/lib/libfontconfig.so.1 (0xb6960000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb665f000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb65e7000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb65cf000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb65bb000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb65b2000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb657f000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb6526000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb6503000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb6500000)
libdl.so.2 => /lib/libdl.so.2 (0xb64fc000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb645b000)
libnss3.so => /usr/lib/seamonkey/libnss3.so (0xb635c000)
libsmime3.so => /usr/lib/seamonkey/libsmime3.so (0xb6338000)
libssl3.so => /usr/lib/seamonkey/libssl3.so (0xb6308000)
libplds4.so => /usr/lib/seamonkey/libplds4.so (0xb6305000)
libplc4.so => /usr/lib/seamonkey/libplc4.so (0xb6301000)
libnspr4.so =>



Posted on 19 Jan 2010, 8:55 by BarryK
Flashplayer SM deps, contd
I meant flashplayer, not mplayer!

Previous post was too long, the rest of it:

/usr/lib/seamonkey/libnspr4.so (0xb62cd000)

libm.so.6 => /lib/libm.so.6 (0xb62a5000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb6297000)
libc.so.6 => /lib/libc.so.6 (0xb6157000)
/lib/ld-linux.so.2 (0xb76ed000)
libxcb.so.1 => /usr/X11R7/lib/libxcb.so.1 (0xb6142000)
libXau.so.6 => /usr/X11R7/lib/libXau.so.6 (0xb613f000)
libSM.so.6 => /usr/X11R7/lib/libSM.so.6 (0xb6138000)
libICE.so.6 => /usr/X11R7/lib/libICE.so.6 (0xb6124000)
libz.so.1 => /lib/libz.so.1 (0xb6113000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb60f6000)
libXinerama.so.1 => /usr/X11R7/lib/libXinerama.so.1 (0xb60f3000)
libXi.so.6 => /usr/X11R7/lib/libXi.so.6 (0xb60e7000)
libXrandr.so.2 => /usr/X11R7/lib/libXrandr.so.2 (0xb60e0000)
libXcursor.so.1 => /usr/X11R7/lib/libXcursor.so.1 (0xb60d7000)
libXcomposite.so.1 => /usr/X11R7/lib/libXcomposite.so.1 (0xb60d4000)
libXdamage.so.1 => /usr/X11R7/lib/libXdamage.so.1 (0xb60d1000)
libXfixes.so.3 => /usr/X11R7/lib/libXfixes.so.3 (0xb60cc000)
libpixman-1.so.0 => /usr/X11R7/lib/libpixman-1.so.0 (0xb6081000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb6063000)
libXrender.so.1 => /usr/X11R7/lib/libXrender.so.1 (0xb605b000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb5ff9000)
libresolv.so.2 => /lib/libresolv.so.2 (0xb5fe5000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb5fca000)
libnssutil3.so => /usr/lib/seamonkey/libnssutil3.so (0xb5fb1000)
libuuid.so.1 => /lib/libuuid.so.1 (0xb5fad000)



Posted on 23 Jan 2010, 17:30 by BarryK
Gnome-mplayer
ttuuxxx,
I compiled dbus, dbus-glib, and gnome-mplayer, but it doesn't work.

I have got the dbus daemon running, no errors reported. Gnome-mplayer starts without any error messages, but when I open a video file there is just an empty window. That's it, still no error messages, just an empty window.



Posted on 23 Jan 2010, 17:45 by ttuuxxx
Gnome-mplayer
Hi Barry I'll have a look next time I have Quirky running:) thanks for trying.
ttuuxxx


Posted on 24 Jan 2010, 9:30 by BarryK
Gnome-mplayer now working
I sent an email to Kevin, and we sorted out what is wrong. I now have Gnome-mplayer working. I'll post more details soon.



Posted on 24 Jan 2010, 20:16 by ttuuxxx
gnome mplayer
That's great Barry Gnome Mplayer when I had Gnome Mplayer going on Upup-J fullscreen worked really nice, the taskbar on jwm would gradually scroll off the screen. even if Gxine didn't work fullscreen Gnome Mplayer did.
ttuuxxx