Fix for black backgrounds in icons

This has been reported in the JWM menu in Quirky, plus some other puplets.

Coolpup thinks that it is the version of the pixman package used in Quirky, and has posted these PETs:

http://puppylinux.org/wikka/pixman

Please test in Quirky 013 (or whatever puplet has the problem) and report back!


Posted on 31 Mar 2010, 9:19


Comments:

Posted on 31 Mar 2010, 9:52 by q013
datafilehost pixman
If you try to download from http://www.datafilehost.com/download-58fd0f15.html

and you are using privoxy, you may need to toggle it off temporarily. Definitely so if it is set to advanced.


Posted on 31 Mar 2010, 9:56 by james c
success
Installed the first pet Pixman-017.14 q.pet and tested in 1024x768x16 and 1024x768x24 with no black backgrounds appearing behind the icons.
Onboard Intel 810 graphics.


Posted on 31 Mar 2010, 10:12 by q013
datafilehost pixman
And it works!

Just note that you will have both versions on your system: the original in /usr/X11R7/lib and the new one in /usr/lib. Doesn't seem to matter yet.


Posted on 31 Mar 2010, 12:08 by broomdodger
acer TravelMate 4670
Is there a way to edit a comment after posted?

acer TravelMate 4670
-Computer-
Processor : 2x Genuine Intel(R) CPU T2300 @ 1.66GHz
Memory : 1024MB (122MB used)
Operating System : Puppy Linux 0.01
User Name : root (root)
Date/Time : Tue 30 Mar 2010 09:01:02 PM GMT+8

All works as with the Toshibas, additionally tried:

+ imported my quirkysave from 010

+ console
- smartctl compiled in quirkey 010
- vim compiled in quirkey 010
- ls -la

+ sns eth0

+ xorgwizard
- 1280x800x16 ok icon-background ok
- 1280x800x24 ok icon-background black
+ pixman 0.17.14
- 1280x800x16 ok icon-background ok
- 1280x800x24 ok icon-background ok

+ seamonkey browse ok
- seamonkey will not open local files with space in name by click
- this is inherited from firefox

+ abiword open 90 page .doc file ok

VIDEO REPORT

Chip description:
Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller

Driver used by Xorg:
intel

Video mode used by Xorg:



Posted on 31 Mar 2010, 14:31 by broomdodger
Dell Inspiron 5150 notebook

Dell Inspiron 5150 notebook

-Computer-
Processor : Mobile Intel(R) Pentium(R) 4 CPU 2.80GHz
Memory : 514MB (74MB used)
Operating System : Puppy Linux 0.01
User Name : root (root)
Date/Time : Tue 30 Mar 2010 11:17:00 PM GMT+8

Again... everything works as with the Toshibas and acer.

+ viewnoir ok
+ paint ok
+ draw ok

pixman-0.17.14-q.pet
1024x768x16 ok icons ok
1024x768x24 ok icons ok

Have you dropped the temperature that was in the battery monitor?



Posted on 31 Mar 2010, 15:01 by BarryK
Temp
I went back to 'asapm', as used in Pup 431, as my own bat/temp applet is buggy and unfinished.



Posted on 31 Mar 2010, 15:09 by broomdodger
Dell Inspiron 5150 notebook
I found "PupScan interface information"!

Dell Inspiron 5150 notebook

DESCRIPTION: VGA compatible controller:
nVidia Corporation NV34M [GeForce FX Go5200 64M]



Posted on 31 Mar 2010, 15:48 by eprv
pixman
That fixed the icon problem
Intel 82945 detected driver intel no dri
the mesa-7.6-q1 is not working, probably not compatible
the upcoming puppy5 is great news
thanks



Posted on 31 Mar 2010, 18:11 by Terryphi
Fixed it!
That fixed the icon problem for me - and also the problem I reported about Osmo smearing text on fast scroll.


Posted on 31 Mar 2010, 18:19 by 01micko
lupu JWM
It seems I have fixed it for playdayz' Lupu too, confirmed by Bm.

I posted a pet ONLY FOR LUPU ...
http://www.murga-linux.com/puppy/viewtopic.php?t=54026

The Quirky pet did not work. There is no /usr/X11R7/lib directory in lupu (where coolpup's .pet installs for Quirky)so I plonked the lib in /usr/lib and it worked.

Cheers


Posted on 31 Mar 2010, 23:56 by aarf
washed out icons q10 and lupu002
exactly the same for quirky 010 and lupu002

have only pwidgets2.2.5.pet and pixman-0.17.14-lupu.pet
x24 colour, yes they haven't got black backgrounds but....

http://www.murga-linux.com/puppy/viewtopic.php?p=406172#406172


Posted on 31 Mar 2010, 24:01 by aarf
washed out icons ctd
edit above: quirky10 has the pixman-0.17.14-q.pet
lupu002 has pixman-0.17.14-lupu.pet


Posted on 31 Mar 2010, 24:03 by libpixman-1.so.0.17.10
libpixman-1.so.0.17.10
libpixman-1.so.0.17.10 from the link to datafilehost installs to /usr/lib.


Posted on 31 Mar 2010, 24:51 by aarf
libpixman-1.so.0.17.10
libpixman-1.so.0.17.10

if this is for me i cant find the link to get it.
google is no help either.
http://www.google.com/search?hl=en&q=%22libpixman-1.so.0.17.10%22+site%3A+http%3A%2F%2Fwww.datafilehost.com%2F&btnG=Search&meta=&aq=f&aqi=&aql=&oq=&gs_rfai=


Posted on 1 Apr 2010, 19:54 by 01micko
JWM
JWM is at 474 dated 24 March 2010

Cheers


Posted on 2 Apr 2010, 6:17 by 01micko
No change
ok, tried jwm-474, no change still the same issue.