Gnumeric rollback

Quirky 018 and Wary 019 have Gnumeric 1.8.4, compiled in T2. Testers report that it crashes when you select Format -> Cells in the menu.

I tried to compile Gnumeric 1.10.1 and 1.10.2, but both have errors in their configuration scripts and I was unable to compile them.

So, I am rolling back to version 1.8.2, the same PET package as used in Puppy 4.3.1. Ditto for Goffice, rolled back to 1.6.3.

If anyone has created a later Gnumeric PET (and Goffice) that actually works, let me know and I'll use it!


Posted on 21 Apr 2010, 17:23


Comments:

Posted on 21 Apr 2010, 22:18 by Jemimah
1.10.0
Puppeee has Gnumeric 1.10.0, which I compiled against goffice 0.8 and libgsf 1.14.7. And it doesn't crash when you go to format->cells.


Posted on 21 Apr 2010, 23:04 by technosaurus
libtool script in goffice/gnumeric
I had to do some minor editing to the libtool scripts in gnumeric and goffice in order to get them to compile properly. (v1.10.0 and v0.8) After that it was smooth sailing. It is in the 4.4 alpha 1.


Posted on 21 Apr 2010, 24:49 by Sit Heel Speak
goffice 0.8 in lucid
The official Lucid Lynx goffice-0.8 .deb's download and 2createpackages has no problem with them, if you make these changes in DISTRO_PKGS_SPECS-ubuntu-lucid to reflect the actual names of the .deb's:

no|goffice|libgoffice-0-8,libgoffice-0-8-common,libgoffice-0-8-dev|exe,dev,doc,nls
yes|libgoffice-0.8-8|libgoffice-0.8-8|exe,dev,doc,nls
yes|libgoffice-0.8-8-common|libgoffice-0-8.8-common|exe,dev,doc,nls
yes|libgoffice-0.8-dev|libgoffice-0-8-dev|exe,dev,doc,nls


Posted on 22 Apr 2010, 3:52 by Sit Heel Speak
goffice or koffice?
1.6.3 not 0.8...perhaps you were thinking of koffice?

Just add this line to
DISTRO_PKGS_SPECS-ubuntu-lucid

yes|koffice|koffice-libs,koffice-data,koffice-dev|exe,dev,doc,nls

Wuh-lahhh, koffice-2.1.2...

Whether it *works well* or not, I haven't tried...