Nvidia PET for Lupu

I have created a Nvidia PET package for Lucid Puppy. Works for me. Get it from here:

http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-5/nvidia-195.36.15-k2.6.33.2.pet

Lupu developers (with Nvidia hardware), for testing recommend download it then run in a terminal:

# petget `pwd`/nvidia-195.36.15-k2.6.33.2.pet

...so you can see if any errors during installation.

A window will pop up with some instructions, need to exit X and run 'xorgwizard'. After restarting X, the NVIDIA Settings application is available in the Setup menu.

I suggest maybe an offer to install this PET can be made in the initial first-boot window. Maybe it could be offered conditional on Nvidia hardware being detected:

# lspci | grep -i 'nvidia'

Lupu will start X using the 'nv' or 'vesa' drivers. You probably don't want to build the nvidia driver into the .iso as the PET is 23MB, but the offer to download and install it would be very good.

For next Lupu beta, I recommend use the latest Woof (May 5). It has improved Xorg Wizard, amongst other things.


Posted on 7 May 2010, 18:19


Comments:

Posted on 7 May 2010, 18:42 by 01micko
lupu nvidia pet
Hmmm..

Maybe a drivers page in quickpet? There is already the radeonHD driver in there. Maybe some other drivers too as they surface.

Cheers


Posted on 7 May 2010, 21:43 by Raffy
Xorg secret?
Just curious how LuPup 114 was able to automatically configure my kid's 1366x768 screen x nVidia (GeForce 6150SE) combination without the nVidia pet?

There must be something different in LuPup, as Puppy's interactive scripts can get only 1360x768.


Posted on 8 May 2010, 5:49 by panzerpuppy
RadeonHD is officially dead
The RadeonHD driver is now officially DEAD !

http://www.phoronix.com/scan.php?page=news_item&px=ODIwOQ

There's no reason to offer this driver anymore for any Linux distro, including Puppy.

xf86-video-ati (a.k.a. radeon) is the only good open-source driver for ATI cards.
It already includes all the features of RadeonHD and works much better.

RadeonHD was a non-working pile of cr*p.



Posted on 8 May 2010, 7:36 by jim1911
lupu nvidia pet
This one works great on lupu-116 including the nvidia settings application.
Thanks,
Jim


Posted on 8 May 2010, 9:32 by BarryK
nv driver
Raffy,
There's no secret. Xorg would have used the 'nv' or 'vesa' driver for your child's PC. These are just slower and less capable than the 'nvidia' driver.



Posted on 8 May 2010, 13:18 by 8-bit
lupu NVIDIA pet
After a mistype of the command from terminal to install the Nvidia pet, I did a pfix=ram boot, then exited to prompt and ran xorgwizard.
then xwin and a terminal window and ran your suggested command line.
No errors on install.
Restarted Xwin.
card driver shown as nvidia.
nvidia-settings worked and so I have to complement you on a very good job.



Posted on 8 May 2010, 13:38 by 01micko
nvidia pet
Barry

Do you think it is possible to add a pinstall.sh script with a little xmessage saying that "when you click okay you will be dropped into console mode then xorgwizard will start" (or words to that effect) snd then add the code from xorgwizaed that kills X snd starts xorgwizard?

Only thing, will need backup if it fails I guess, but then again xorgwizard will pick a driver appropriate to the card.

I would have tried the above but I only have an old vanta card to test.. not likely to work!

Cheers


Posted on 8 May 2010, 21:21 by BarryK
nvidia pet
01micko,
There is already a pinstall.sh script with an xmessage with instruction. Requires manual exit from X though.



Posted on 9 May 2010, 7:17 by 01micko
driver tab in quickpet
Thanks for reply Barry

I have integrated a driver tab in the quickpet gui. When a user clicks the driver icon a yes/no box pops up explaining the xorgwizard/xwin routine and offering a choice to continue or not. So they get to look at the instructions twice! Good!

Cheers


Posted on 9 May 2010, 8:52 by BarryK
23MB Nividia PET
I wonder if QuickPET should mention that the Nvidia PET is 23MB in consideration of those on dialup?



Posted on 10 May 2010, 10:40 by EdD
GLX?
Wheres GLX in this config? GLX info and Gears say no GLX on device 0.0? I have tried everything I can think of but can not seem to acticvate it on Lupu or quirky since its release? SHould I try to build Nvidia driver w/ Kernel is there an older one I can revert too?


Posted on 10 May 2010, 17:59 by BarryK
GLX in Quirky/Lupu
EdD,
GLX is left out of both Quirky and Lupu.

Playdayz did have it in Lupu, but there was some trouble so took it out. He might provide a PET package later if anyone wants to add it.

With Quirky 1.0, you should be able to add GLX by running the Puppy Package Manager and install the 'mesa' PET package, from the 'puppy-quirky' repository (use Search to find it).
Then edit /etc/X11/xorg.conf and change "Disable "glx"" to "Load "glx"".
...then cross your fingers and restart X.

...if GLX still fails, look at /var/log/Xorg.0.log for clues.



Posted on 17 Jun 2010, 5:13 by Doug Smith
Error loading kernel mod.
I'm trying desperatly to get my second monitor to work so, I need the nvidia drivers as the nv and VESA don't work. For some reason I get the error below even though the file exist I think the module can't find my card. I have the Quadro NVS 280 PCI which the drivers says will work.

# petget ./nvidia-195.36.15-k2.6.33.2.pet
FATAL: Error inserting nvidia (/lib/modules/2.6.33.2/misc/nvidia.ko): No such device


Anyone ever run into this problem? Do I need to recompile the kernel? I hope not because all I have is a terminal with 1 Gig of flash and the kernel is rather large.


Posted on 17 Jun 2010, 8:28 by Doug Smith
173.14.x.x .pet?
Well I dug deeper and found another error. I tried downloading a .pet of 173.14 but the kernel is wrong and probably for puppy 4.x. Is there a lupu .pet for 173.14?