e3 2.8

e3 is a tiny text editor, found in all puppies. Most versions of Puppy, Quirky included, have a 7-bit ASCI build of e3, as the UTF8 build was buggy.

However, version 2.8 has been released, with UTF8 bug fixes.

Get it from here:
http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-quirky/e3_utf8-2.8.pet

...this will work in all puppies, but I think needs to run in the rxvt-unicode terminal. Um, I'm not sure about that ...older puppies have a non-UTF rxvt.

e3 home page:
http://sites.google.com/site/e3editor/


Posted on 29 May 2010, 21:30


Comments:

Posted on 30 May 2010, 2:13 by broomdodger
e3 2.8 works better
quirky 112 frugal
e3 2.8 no longer gives errors when .Xdefaults sets geometry, such as:
Rxvt.geometry: 88x44+3+33

/etc/profile has an alias:
#v4.00 run e3vi whenever vi excuted...
alias vi=e3vi

BusyBox has its own version of vi which IMO is much better. Please remove the alias.




Posted on 30 May 2010, 3:19 by Iguleder
+1
I think many people will find the minimal Busybox Vi much better than e3.

Please remove either e3 or that alias ... Thank you!


Posted on 30 May 2010, 8:19 by BarryK
Re vi
Ok, I have removed the alias.



Posted on 30 May 2010, 16:59 by Iguleder
Thank you!
Thank you very much, Barry :)