Using an older kernel

Some useful information for Puppy developers...

The 'linux-headers' (or 'kernel-headers') used in a Linux distro are critical, they determine the oldest kernel that can be used with that distro.

The Linux headers are at /usr/include/linux (when Puppy's 'devx' SFS is loaded).

When the 'glibc' package is compiled, it looks into /usr/include/linux to determine kernel capabilities.

This is critical. The Puppy 4.x series uses linux-headers 2.6.19 -- this means that Puppy 4.x will work properly with any kernel 2.6.19 or later.

The T2 packages compiled for Quirky used linux-headers 2.6.30. Ubuntu Lucid Lynx uses linux-headers 2.6.33.

Right now I'm running Wary with 2.6.27.47 kernel, built with the same T2 packages as used for Quirky, and it seems to be working ok. Really though, I should recompile all the base packages in T2, against the 2.6.27 headers.

...which is what I started to do. That is, compiling in T2 with linux-headers 2.6.27, kernel 2.6.30 .... but then a few minutes ago I read this:
http://www.mail-archive.com/gentoo-amd64@lists.gentoo.org/msg12288.html

As explained above, user-space uses linux-headers. /usr/src/linux is used for building kernel modules. To give examples, x11-drivers/ati-drivers and app-emulation/vmware-modules use /usr/src/linux (kernel sources package), while media-libs/alsa-lib and sys-libs/glibc would use /usr/include/linux (linux-headers package).

...yes, some Xorg drivers look into /usr/src/linux.

So, just now I have aborted the T2 compile, and will restart it using linux-headers 2.6.27 and kernel 2.6.27.


Posted on 8 Jun 2010, 9:43


No comments posted yet.