Udev 151

While in Perth, I didn't get much opportunity to work on my laptop, but did do this...

Udev is, in a nutshell, a daemon that reads system notification messages called 'uevents' from the kernel, and performs appropriate actions. An example of an action is to load the firmware for a module that has just loaded.

Puppy has used Udev version 124 almost from when we first started to use Udev. However, that is now a very old version. Interesting that it still works okay with the latest kernels. There is a certain version recommended for a certain kernel, for example, Udev 151 is recommended for the 2.6.27 kernel. The Udev documentation states that a later version of Udev should not be used, so anything >151 should not be used with the 2.6.27 kernel.

For Wary I decided to move up to Udev 151. It works, but I got warning messages appearing on the screen at bootup -- not errors, just warnings that features in some of the Udev rules are deprecated (modem rules and one cups rule). I set the global variable UDEV_LOG=2 to hide these.

With Udev 124 and 151, there are also some error messages at shutdown with the 2.6.27.47 kernel. This may also have something to do with the rules. I don't understand the messages, but they don't seem to be critical. UDEV_LOG=2 also hides these.

I have created a PET for Udev 151. I'll use this in the next release of Wary and we can give it a good workout. Then, it would probably be a good idea to bump all Woof-built puppies to Udev 151.


Posted on 13 Jun 2010, 9:13


No comments posted yet.