libusb 1.0.8

Wary 030 testers have reported that the sane-backends package needs libusb 1.x for some of the scanner drivers.

I have compiled libusb 1.0.8 in Quirky. Woof will default to using this PET for Wary builds also. I have named the PET package 'libusb1-1.0.8-q1.pet' (and 'libusb1_DEV-1.0.8-q1.pet') so as to have a different name from the old libusb.

libusb 0.1.12 is still required. The libraries do not conflict, that is, can both be installed without conflict. Note that there is a 'libusb-compat' package that provides a wrapper for libusb 1.0.8 to emulate the 0.1.x series, however it is not needed.


Posted on 19 Jun 2010, 19:26


Comments:

Posted on 19 Jun 2010, 21:27 by perthie
More Scanner Tests
I did some more tests with my Canon MP490 scanner. It seems like Canon is the only make that really needs lisbusb-1.0.

I tried installing libusb-1.0.8 but NOT libusb-compat and compiled sane against it. I got the same hangups with my scanner as before. Canon's own scangearmp GUI frontend also failed.

It was only by using both libusb packages that I could it to work. I then did test installs as far back as Puppy 4.1.2 and got successful results with both Xsane and scangearmp.

I have incorporated this into my Canon scanner PETs. Maybe that's good enough, since nothing else appears to need libusb-1.0.