Sane-backends 1.0.21

I already compiled libusb 1.0.8:
http://bkhome.org/blog/?viewDetailed=01668

I have recompiled sane-backends in Quirky, now using both the old libusb 0.1.12 and the new libusb 1.0.8.

'perthie' reported that the libusb-compat package is needed for the Canon driver. Hmmm, that is very odd. I am not going to risk taking out libusb 0.1.12. If that really is the situation, then the Canon driver is broken.


Posted on 20 Jun 2010, 9:48


Comments:

Posted on 20 Jun 2010, 12:54 by Firewave
strange
Strange. In 1.1 my Canon scanner was working by using the updated sane-backends and xsane packages you posted before the 1.2 release. No need for additional packages. It's from the imageCLASS/i-SENSYS series, that is using the pixma driver.


Posted on 20 Jun 2010, 19:33 by perthie
Just for MPxxx Scanners?
I suspect that the problem is in the firmware of certain MP class Canon machines. Both the MP250 and MP490 need the libusb upgrade, and even Canon's own scangearmp scanning software won't run in Puppy without it.