Abiword 2.8.6

I have compiled this in Quirky, up from 2.8.3.

There is one thing that annoys me. I don't recall what version it started, but about 6 months ago I think, Abiword suddenly did not display the images in some documents. For example:

/usr/share/examples/testdoc.doc

I haven't reported it, assumed that it would be noticed and fixed. But no, not yet.


Posted on 21 Jun 2010, 18:54


Comments:

Posted on 21 Jun 2010, 20:40 by AdrianC
no images in .doc
Hello, I been facing this problem much more than a year, i think. No images only in .doc documents. I only use .rtf.
Can this version open .docx files?
Thank you



Posted on 21 Jun 2010, 21:34 by technosaurus
libwv
If my memory serves me correctly the error comes from newer versions of libwv (perhaps it is the way wv is compiled?... I never figured it out, but the old version at least does images) - abiword is probably the only default program that needs wv (unrelated to wvdial) so it should be safe to revert to the older version from pup431.


Posted on 22 Jun 2010, 15:58 by BarryK
wv roll back
I rolled back. Got wv from here:

http://www.abisource.com/downloads/wv/

Version 1.2.5 is the last version that works, so I installed that and recompiled Abiword (necessary).



Posted on 22 Jun 2010, 21:06 by AdrianC
gnumeric quirky retro
Talking about office apps (excuse me please if this was disscused before in your great forum, but I can not reach it anyhow):
I use quirky retro versions, almost since the appeareance of abiword problem, i think, I have noticed also the following:
Boot the last quirky 1.2 retro, open Gnumeric and create a new spreadsheet (.xls o .gnumeric), it can be empty, and save it in the hard disk (ext2, reiser partition). Close gnumeric and open it again, go to file/open and open just created document: It will be imposible to write in any cell; typed numbers will appear in formula's bar, but not inside de cells.
But if you open rox-filer and open the spreadsheet from it, it will open normally. (after quirky1.2retro HD full install the problem dissapears)
Sorry again, and Thank you BK and team.


Posted on 26 Jun 2010, 8:48 by perthie
Libjpeg
Quirky has both libjpeg-7 and libjpeg-62. (Both 4.3.1 and Lupu have only 62.) This is a bit of a nuisance because anything compiled in Quirky won't run in the others without a symlink.

Is this an oversight or is there a reason for 7?


Posted on 26 Jun 2010, 9:15 by perthie
My Mistake
It looks like 7 is newer than 62.