Slackpup 0.4 (beta)

Our latest experimental Puppy based on Slackware 13.1 binary packages. Get him from here:

http://distro.ibiblio.org/pub/linux/distributions/quirky/test/spup-0.4/

...you will find the 'devx' SFS file there also. If you want the kernel source SFS (2.6.34.1), go here:

http://bkhome.org/sources/kernel-2.6.34.1/
username: pu#p#py password: li#n#ux (remove #s)

If you want to test the Nvidia PET (23MB):

http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-quirky/nvidia-195.36.31-k2.6.34.1-s131.pet


Posted on 10 Jul 2010, 8:46


Comments:

Posted on 10 Jul 2010, 10:22 by aarf
background changer?
background changer?


Posted on 10 Jul 2010, 10:24 by BarryK
Samba printing
See this post:

http://murga-linux.com/puppy/viewtopic.php?p=433211#433211



Posted on 10 Jul 2010, 10:28 by BarryK
Re wallpaper
Oops, the package I created is wrong, move /usr/share/wallpaper.desktop to /usr/share/applications/, then run "fixmenus" in a terminal.



Posted on 10 Jul 2010, 10:34 by BarryK
Re fixmenus
What?! I thought "fixmenus" will restart JWM to update the menu. It didn't, will have to check that out. Anyway, do this in a terminal:

# jwm -restart



Posted on 10 Jul 2010, 10:37 by aarf
wifi disconnecting
wifi held in spup03.
it is disconnecting in spup04 although remembering through reboot.


Posted on 10 Jul 2010, 10:41 by BarryK
Spup 0.4 forum feedback
Here is a forum thread for feedback:

http://murga-linux.com/puppy/viewtopic.php?t=57374&start=30



Posted on 10 Jul 2010, 10:49 by edoc
You are amazing!
Downloaded ... may be too late in the day here to load it all up but will make a point of it asap and report back.

Thanks!


Posted on 10 Jul 2010, 20:16 by aarf
pwidget-wireless
"wifi disconnecting
wifi held in spup03.
it is disconnecting in spup04 although remembering through reboot."
pwdgets-wireless-widget is working in spup4 but wasnt working in spup3. could it be a cause of wifi disconnection problem?.


Posted on 10 Jul 2010, 20:37 by BarryK
Re Pwidget-wireless
I don't know. Any bug reports for Spup 0.4 about wifi should be for the pristine Spup. If installing Pwidgets causes some problem then you need to contact the Pwidgets maintainer.



Posted on 11 Jul 2010, 3:07 by perthie
Smbclient Problems
See my bug report (rcrsn51) regarding the new samba_tng_client package.


Posted on 11 Jul 2010, 15:39 by aarf
wifi disconnecting
now running spup04 with pwidgets stopped.
wifi still disconnecting. IF it is pwidgets that caused the problem, it is persistent.


Posted on 11 Jul 2010, 21:49 by BarryK
new printing script
perthie,
Patriot has created a new printing script that works with both Samba's:

http://bkhome.org/blog/?viewDetailed=01721



Posted on 13 Jul 2010, 3:13 by aarf
spup04 pfix=ram wifi disconnecting
spup04 pfix=ram in the time it makes to type a simple message wifi will disconnect, then i have to go in to sns and reconnect again. something in this department has definitely changed since spup03


Posted on 13 Jul 2010, 8:59 by BarryK
Re wifi disconnecting
Kernel upgraded from 2.6.34 to 2.6.34.1, only major change in configuration is now SMP.

Reintroduced the 'acpid' package. This was missing from Spup 0.3 and 0.2. The daemon 'acpid' is started when X starts, in /root/Startup/acpi.

...so, what you could try is boot with "puppy pfix=ram,nox", then:

# rm /root/Startup/acpi
# xwin