Wary Puppy 0.6

Wary 0.5.1 was released a short time ago, see announcement:
http://bkhome.org/blog/?viewDetailed=01762

If you read my blog posts since then, you will see various improvements and bug fixes, and I have now uploaded Wary 0.6. Download from here:
http://distro.ibiblio.org/pub/linux/distributions/quirky/wary-060/

...there are .delta files to make it easy if you already have downloaded Wary 0.5.1.

delayedrun
I previously posted about fixes for the 'delayedrun' script:
http://bkhome.org/blog/?viewDetailed=01770
However, in line 86 you need to delete the "exec" -- "exec" causes the script to exit -- this is only an issue if 'first-run.sh' is installed, which it isn't in Wary -- so you don't need to fix it, I am just pointing it out.

gmplayer and JWM
Wary 0.6 has gmplayer (mplayer with GUI) but it does not work when JWM is set to 16-bit color depth -- you must choose 24-bit in Xorg Wizard.

Note, SMPlayer is a PET in the 'puppy-wary5' repo that you can install from the PPM.

SeaMonkey and JWM
On the otherhand, SM renders some sites scrambled when set to 24-bit and you must use 16-bit!
For example, 01micko's site:
http://users.tpg.com.au/01micko/01mickos_tools.html

I have the above two problems with Intel Xorg driver, not Xvesa. I don't know about other Xorg drivers, but there was at least one report of the same problem with a different driver in 0.5.1.
I posted a bug report to Joe at his sourceforge bug-reporter, some time ago -- today I have emailed a reminder.


Posted on 20 Sep 2010, 17:03


Comments:

Posted on 22 Aug 2010, 9:17 by BarryK
PPM: SMPlayer problem
I found that PPM is broken, can't install SMPlayer from the 'puppy-wary5' repo. I know what the problem is, but I can't fix it right now.

Instead, download the PET and click on it to install it:
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-wary5/smplayer-0.6.9-static_qt-w5.pet



Posted on 22 Aug 2010, 17:20 by 01micko
my site is bad!
Well, it's not confined to intel, using nv driver on a fastish card and my site looks terrible! Do you think it's a mozilla bug? People in Lupu have been complaining about Seamonkey and Firefox, choppy scrolling, unreadable sites etc, but I'm yet to see it until the latest Wary!

I produced that site with Kompozer.. I had a peek at the code and didn't like it at all, but it worked ok in netsurf, SM, FF and Chrome so I uploaded it.

If you look at my fun site on the same server it renders just fine.. (coded entirely by hand)
http://users.tpg.com.au/01micko/

Also, my tools site renders just fine in Opera 10.61., advertised on playdayz Lucid Puppy News site (and he recommends Icewm, I think that's a flash issue, never use Opera myself, but may need to in Wary).
Opera <-- ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet-packages-lucid/Opera-10.61-Lucid.pet (there you go sage)

Pmusic is there ok, so my experience with woof must have been a weird one off.

Just some initial testing..

..later.. I installed Icewm and it worked fine in Wary... which prompted me to return to my woofed lucy.. Icewm was fine but no tray icons.. had an old delayedrun file.. could have been legacy on my part though because I didn't delete all my old woof pets. Will be more careful next time.

So, opera and Icewm work great for me in Wary, flashplayer too. That's good I guess.

Cheers


Posted on 22 Aug 2010, 24:33 by x86
smplayer & mplayer
after installing smplayer, neither mplayer or smplayer would launch from menu. The mplayer.desktop and smplayer.desktop had an extra "exec" in the Exec line:
Exec=exec mplayershell
removed exec from both and they launch fine now.

smplayershell had this line at bottom:
exec smplayer $@
Is that ok or is this way ok?
exec smplayer "$@"


Posted on 23 Aug 2010, 3:33 by Sage
Even more video woes
Black screened with an ATI card, even though XOrg Probe gives correct options confirmation. nV cards seem OK.
These recent video issues threaten to kill the golden goose. They have been incessant!


Posted on 23 Aug 2010, 3:43 by james c
video stuff
Wary 0.6 Default SeaMonkey onboard Intel 810 graphics. 01micko's site looks fine from here.

Could it be another JWM bug?


Posted on 23 Aug 2010, 4:55 by video stuff
james c

Running 1024x768x24.


Posted on 23 Aug 2010, 5:09 by x86
users.tpg.com.au
it looks fine in dillo, ff, sm here. 24 bit xorg ati

could be something here, but i doubt it:
http://validator.w3.org/check?uri=http://users.tpg.com.au/01micko/01mickos_tools.html


Posted on 23 Aug 2010, 8:52 by perthie
ATI Xvesa OK
My ATI Radeon Xpress card now works in Xvesa. I can live without Google Earth.


Posted on 23 Aug 2010, 11:16 by FeodorF
SM-206 please check this!
Hi Barry,

if I set up my screen to 1024x768x24bit I`ll have trash within 01micko`s page. Fact. If you pop up View - Use Style - Default Style change the value to None and you will be surprised - as the page looks all wright now. [At least mine did.]

I think that should proof to the Mozilla crew, that it is there turn now. Why? Because SM-206 keeps copying the screen memory values into their window.

Regards, Feodor


Posted on 23 Aug 2010, 16:43 by session
Wary with r128 and mga drivers
Using r128 driver; this bad rendering in Seamonkey is Wary-specific for me, since 0.30. Lupu and Quirky render fine, as does 4.3.1 with latest Xorg driver and SM 2.0.6.

Keyboard navigation for JWM doesn't work, it did in 0.5.1.

Wow, I just tested this on another card, a Matrox G200. Same render problem, but I can for the first time ever reach 24bit depth at the highest resolution. Tested and yes, Quirky can reach it too, but it's WAY slower, under any depth...


Posted on 23 Aug 2010, 21:07 by FeodorF
I apologize to the Mozilla crew
Sorry folks! I was wrong with my blame on Mozilla.

This morning I have installed wary puppy 06 on my old PII-266 Deschutes with Intel 440LX and ATI 3D IIC AGP.

I have tested the 24-bit mode in 1024x768 and 1280x800 [01mickos page] resolution. The picture was perfect.

I did the same testing on my PIII-933 Cuppermine with an 1/2 year older ATI 3D IIC AGP and the result was negativ - a no go for 24-bit.

And now - frustration.

Regards, Feodor



Posted on 24 Aug 2010, 21:40 by gjuhasz
Compatibility
First of all, thanks, Barry!
1. I don't see noticeable rendering problems. There are minor ones for some sites, that can be resolved by forcing usage of Seamonkey's own fontset.

2. Libs: I use multiple Seamonkeys, 2.1 alpha for root and 2.0 6 for spot. For this, I had to install missing libs requested by 2.1. Note that spot browsing (because of the "older" Seamonkey?) is much slower. Get an ancient PII 256 MB machine and compare with

http://egyszervolt.hu/anim/matyas-rulez.html

3. Multimedia: Compared to other puppies, this Wary is extremely fast. The last mplayer pet shows all test videos including .webm files on my 400 MHz PII 256 MB Toshiba Tecra (neomagic driver) well.

4. I am still suffering with installing mesa driver. Tried different pets. Note that glx and Xorg.high works under Lupu.

5. Although Pwidgets runs under Wary, it blocks other apps such as Geany and Skype regardless to the combination of widgets selected. Even if no widgets selected, or while pwidgets is stopped, Geany and Skype refuse to start.
I tested with Wary 030, 051 and 060, in a few virtualized and real environment. If I remember well, only older versions of pwidgets can be forced to start.
As soon as I deinstall Pwidgets, Skype and Geany resurrect.

Other Puppies (Lupu, Slackpup) have no compatibility issues with Pwidgets.

6. Unfortunately, virtualized environment (VirtualBox, VMware) still dislike Wary. I can use xvesa only - the good news is that the control keys are OK now.


Posted on 30 Aug 2010, 4:50 by peebee
Touchpad problem
Wary 0.6 on HP550 laptop
Can't configure the touchpad - FlSynClient gives an error message about unable to access shared memory
Thanks
Peter


Posted on 31 Aug 2010, 6:13 by broomdodger
Windows applications making GRUB 2 unbootable
Windows applications making GRUB 2 unbootable

<http://www.chiark.greenend.org.uk/ucgi/~cjwatson/blosxom/debian/2010-08-28-windows-applications-making-grub2-unbootable.html>



Posted on 1 Sep 2010, 18:03 by scsijon
d/l problem wary060?
barry, trying to download the wary-060.iso is just sitting in a "begining ftp", not going anywhere. Can you check it out please

regards
scsijon


Posted on 1 Sep 2010, 18:05 by scsijon
d/l problem wary060?
oh yes, and the devx is ok so it's not a speed problem.


Posted on 1 Sep 2010, 18:34 by BarryK
Wary 070 coming soon
Probably a temporary hitch at ibiblio.org, but don't know why it should affect one file.

Anyway, the next Wary will be uploaded soon.



Posted on 1 Sep 2010, 18:52 by xman
24 bit is essential
Laptop '03, amd athlon.

Yes, 24 bit Xorg is a solution.

I tried first 060 with 16 bit Xorg, but almost everything was more or less green. Then I changed to vesa, but gave up after massive crash and corrupted savefile. 2.6.32.16 is so big kernel number that I even haven't expected anything else.

After reading that 24 bit is needed, it was time to second try. This time I updated from 030 to 060. Now I listen African jazz, old processor goes at 55 degrees Celsius, and it's so nice. Mplayer is very OK, browsers also (SM, FF, O and C). Update downgrades flash from 10.1.82 to 10.1.42. Deleting 10.1.42 didn't make puppyspace any bigger, and 12 mb more was needed for updating.

060-bug in Calc: When I choose column from table, and then Format Cells, Calc crashes.

Thanks for Wary-060, and especially for Retrovol with memory!


Posted on 2 Sep 2010, 7:10 by scsijon
d/l problem wary060?
eventually started d/l at 183bytes bandwidth so killed it,

will wait 070 with bated breath.

regards
scsijon