Wary: intel: scrambling fixed

A problem was reported in Wary 0.6, with 24-bit color depth, rendering some websites is scrambled:

http://bkhome.org/blog/?viewDetailed=01771

I thought that this was a problem with JWM, but I found that the problem does not occur with the 'i810' Xorg driver, only the 'intel' driver (both of these drivers work on my laptop).

FeodorF has been very helpful and has reported the same problem with an ATI video card, and has also sent me a pm with analysis that identifies the problem is with the Xorg driver.

Anyway, I have fixed the problem with my Intel video. Wary 0.6 is built with the 'intel' driver version 2.1.1. I downloaded version 2.3.2 as used in Debian Lenny, and also applied the patch file from Lenny. I compiled and installed it, and now 01micko's site renders properly.

What I will do next is roll the ATI drivers back to the same as used in Lenny.


Posted on 20 Sep 2010, 17:01


Comments:

Posted on 31 Aug 2010, 11:36 by broomdodger
retrovol confguration
retrovol confguration > tray > tray slider

wary 060

I am not able to change the tray slider.
Sometimes selecting an item retrovol just disappears.



Posted on 31 Aug 2010, 11:53 by BarryK
Wary: ati rollback
Ok, I have compiled the ati, mach64 and r128 drivers from Lenny.



Posted on 31 Aug 2010, 16:49 by BarryK
Intel: screen flicker back
Aaargh! <expletive>
I'm running with the intel 2.3.2 driver, and it is fine, but that very annoying occasional flicker is back. I don't recall, there must have been a reason that I was using the older 2.1.1 driver.

With these intel drivers, you can't win.

Anyway, I'll experiment with some other versions.



Posted on 31 Aug 2010, 18:42 by BarryK
Intel driver 2.2.1
I compiled intel driver 2.2.1 which is used in Debian Etch, and I used the patch from Debian.

Using it now, waiting for a flicker...



Posted on 31 Aug 2010, 20:24 by BarryK
2.2.1 no flicker
I have been using it for over an hour, haven't noticed any flicker. Ok, will use this one.



Posted on 31 Aug 2010, 20:28 by BarryK
2.2.1 no good
It's a conspiracy against me!!!

I an running with intel driver 2.2.1, and no screen flicker, but I have just checked 01micko's site, and it is scrambled.



Posted on 1 Sep 2010, 10:34 by session
Should you rollback?
Testing ATI r128 and mga, I've had the page scrambling with several driver versions. Is it the enhanced Xorg? Patriot's drivers for xorg-server 1.3--newer than the drivers in Debian Lenny--render fine.

Whatever the case, this version of Xorg is faster on the old ATI than the one in puppy 4.


Posted on 1 Sep 2010, 17:50 by ChrisThomas
Nvidia RIVA TNT
I have website rendering problem with this old Nvidia RIVA TNT2 hardware in the default SeaMonkey


Posted on 1 Sep 2010, 19:46 by BarryK
No flicker with mesa
I am running Wary with Intel 2.3.2 driver and the full mesa openGL/DRI package, and no flicker so far.

The full mesa package is 11MB PET, so bumps the live-CD to 118MB. I'll keep the mesa package in for Wary 070.