Wary: flsynclient fixed

Wary 0.6 testers reported an error message when Flsynclient (the Synaptics touchpad configuration GUI, PET created by Jemimah) is started:

Can't access shared memory area: SHMConfig disabled?

I examined /var/log/Xorg.0.log and found that the Xorg Synaptics module was failing. Wary was compiled with the Synaptics driver version 1.0.0, so I compiled the latest, 1.2.2. However, Flsynclient then gave this message:

Incorrect size of shared memory area. Incompatible driver version?

I then compiled the Synaptics driver version 1.1.3, and now Flsynclient works.

Note, I downloaded the Synaptics drivers from here:
http://xorg.freedesktop.org/releases/individual/driver/


Posted on 20 Sep 2010, 17:00


Comments:

Posted on 1 Sep 2010, 9:44 by Barry Kauler
Wary: flsynclient fixed
Is your calendar different in Australia than USA?
Note date posted was 32 Aug 2010.
USA stops at 31 Aug
Just curious
yarddog


Posted on 1 Sep 2010, 16:24 by ChrisThomas
Quirky Fans
I am a Quirky Fan because it is very stable than Puppy 5.1 but Wary 0.6 is much stable than Quirky.

I hope there will be many things new in Quirky

I read a vulnerability here

http://techie-buzz.com/foss/highly-critical-vulnerability-in-the-linux-kernel-fixed.html


Posted on 10 Jul 2011, 4:20 by PhilFox
flsynclient not fixed
5.1.2 still has the error

Can't access shared memory area: SHMConfig disabled?


How do us newbies get this fixed?