Kernel 2.6.30.5 updated PET

I posted today about recompiling the 2.6.30.5 kernel:
http://bkhome.org/blog/?viewDetailed=01794

The PET is here:
http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-quirky/linux_kernel-2.6.30.5-tickless_smp-11-p4.pet

This PET can be used for all Woof-built puppies based on the 4.x series (such as the various experimental 4.3.2 builds), or any Puppy that wants an older kernel.


Posted on 4 Sep 2010, 18:59


Comments:

Posted on 18 Sep 2010, 23:23 by ttuuxxx
Kernel 2.6.30.5
Hi Barry I built the latest woof-build, and based it on 4 series.
4 packages weren't found,
1 wallpaper-0.5.6
2 powerapplet
3 seamonkey_addon_user_agent_switcher
4 seamonkey_addon_flashblock
plus it didn't come with a flash player package
Also the sound didn't work and I'm getting a lot of errors that contain this message.
"/usr/lib/libstdc++.so.6: no version information available"
The release and devX can be found at
http://www.murga-linux.com/puppy/viewtopic.php?t=60026
ttuuxxx


Posted on 19 Sep 2010, 15:13 by ttuuxxx
alsa not autostarting
Hi Barry if I use the alsa setup and manually setup sound it works, when I boot clean this is the xerrs.log before I manually set the sound
kill: usage: kill [-s sigspec | -n signum | -sigspec] [pid | job]... or kill -l [sigspec]
/usr/sbin/delayedrun: line 130: 12507 Segmentation fault retrovol -hide ${BGOPT}
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
aplay: main:608: audio open error: No such device

ttuuxxx


Posted on 1 Oct 2010, 19:24 by dawg
Much appreciated!
Thanks Barry! This solves my P4 auto-throttling problem in Puppy 5.x.

However: now hdparm -S (spindown/standby time) gets ignored (?) - it acts as if everything's OK, but has no effect.


Posted on 1 Oct 2010, 19:28 by dawg
P4
I mean P4 as in Pentium 4 (laptop)