Weird font in SNS fixed

'perthie' has tested Quirky 1.3RC and reports that the "Please wait..." box that pops up in Simple Network Setup (SNS) displays in a weird font.

Ah yes, this has happened because the original 'yaf-splash' package is now installed. Well, not exactly...

Most distros now have Xorg in /usr, whereas T2 places it in /usr/X11R7. So that everything appears in "normal" locations when building a Puppy in Woof from T2 packages, I created a special package named 'zzt2_fixup_hack' that creates symlinks from /usr to all the executables (plus other fixups, see 'pinstall.sh' in zzt2_fixup_hack).

The problem is, this fixup sees /usr/X11R7/bin/yaf-splash and creates a symlink to it from /usr/bin, overriding the previous symlink to /usr/bin/gtkdialog-splash.

Thanks for pointing that out, I have fixed it.
The package is now 'zzt2_fixup_hack-20100921.pet' and I will upload it soon.

A reminder to myself: this fixup package is also used in Wary, but I think that it has some Xorg 7.5 specific stuff, so may have to create another one for Wary.

A reminder to ttuuxxx and others: The Puppy "4.3.2" build also has a zzt2_fixup_hack PET package (if I recall rightly), that will need the fix I have described above. Basically, put a bypass for yaf-splash into pinstall.sh:

for ONEFILE in `find ./usr/X11R7/bin -type f`

do
BASEFILE="`basename $ONEFILE`"
[ "$BASEFILE" = "yaf-splash" ] && continue #100921
ln -snf /usr/X11R7/bin/$BASEFILE ./usr/bin/$BASEFILE
done


...or, if you choose not to include the original yaf-splash PET then the problem will not occur.


Posted on 21 Sep 2010, 15:04


No comments posted yet.