2nd Wary build with 2.6.35.7

First time, I got a kernel panic. I found that the problem was the depmod applet in the new Busybox 1.17.2.

The depmod applet can be configured (prior to compiling) to generate /lib/modules/2.6.35.7/modules.dep with relative paths in the entries, rather than absolute paths. Relatives paths gives compatibility with recent versions of the full depmod.

However, the modprobe in the initrd is an older version that expects absolute paths in modules.dep. Hence no modules got loaded in the initrd.

I fixed that, and the 2nd build worked and I got a desktop, but when I did a mouse-over the welcome message at top of screen, there was no "woof woof".

Ah, the problem is not sound, it is in /usr/sbin/delayedrun. Rerwin's most recent patches have moved the Alsa alias entries out of /etc/modprobe.conf into /etc/modprobe.d/alias-sound_cards. I have fixed the delayedrun script to look in the correct place.

/etc/modprobe.conf is deprecated, and we are gradually relocating everything from /etc/modprobe.conf.

While I think of it, obmixer needs a tweak -- when I click on the tray icon, the bottom half of the popup window is hidden by the JWM tray. It needs to be moved up a bit.

This new Wary is looking good!


Posted on 7 Oct 2010, 21:36


Comments:

Posted on 7 Oct 2010, 21:41 by BarryK
modprobe warning
/tmp/xerrs.log has this:

WARNING: All config files need .conf: /etc/modprobe.d/alias-sound_cards, it will be ignored in a future release.

WARNING: All config files need .conf: /etc/modprobe.d/alias-modem_slmodem, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/install-modem_slmodem, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/apm, it will be ignored in a future release.


Rerwin, if you read this, please note!

The 'apm' file is mine, I'll change that to 'apm.conf' now.



Posted on 7 Oct 2010, 21:51 by BarryK
Retrovol segfaults
Retrovol segfaults. The window appears briefly then crashes.

I have installed the retrovol 0.6 PET that I have been using in Wary and Quirky up until yesterday, and that does not crash.

So, it is Jemimah's patched version that crashes.



Posted on 7 Oct 2010, 22:07 by playdayz
Maverick 2.6.35.7
I built a Maverick Puppy with 2.6.35.7 and it booted and X started. Everything I tried worked *except* sound. It was not just WoofWoof but there was no sound at all. I was using the current Woof. Any chance you could post the new delayedrun. Thanks.



Posted on 7 Oct 2010, 22:14 by BarryK
re delayedrun
playdayz,
My change in delayedrun only fixes the "woof woof". Sound is working in my laptop.

I put this into delayed run:

#101007...

MODPROBECONF='/etc/modprobe.conf'
[ -f /etc/modprobe.d/alias-sound_cards ] && MODPROBECONF='/etc/modprobe.d/alias-sound_cards'

Then a bit further down...

if [ "`grep 'alias snd\-card\-0' ${MODPROBECONF}`" != "" ];then #101007
aplay /usr/share/audio/2barks.au &



...but this is only needed if all of rerwin's latest modem PETs have been applied, which I have done in Woof.



Posted on 7 Oct 2010, 22:57 by BarryK
Mplayer works
Well I'll be a monkey's uncle! Mplayer is now working at both 16-bit and 24-bit color depth! Mplayer likes the old xorg-server 1.3.0.0 that I am now using in Wary (same as in Puppy 4.3.1). Or, more likely it is one of the older Xorg libs that Mplayer likes.

Whatever, I'm pleased.