Wary Puppy 0.9 released

This is a beta-quality release for evaluation and bug-fixing by Puppy enthusiasts.

I have created an introduction page that explains what Wary is all about:

http://bkhome.org/wary/

Forum member tronkel has started a forum thread to discuss how Wary can (or cannot) fit into the "scheme of things":

http://murga-linux.com/puppy/viewtopic.php?t=60657

I created two builds, with 2.6.35.7 or 2.6.30.5 kernels. I recommend chose the most recent kernel, unless you have a particular need for SCSI support or one of the analog modem drivers not provided with the latest kernel. Or, of course, if the recent kernel doesn't work on your hardware, let us know.

Download live-CD ISO files and the 'devx' SFS from here:

http://distro.ibiblio.org/pub/linux/distributions/quirky/wary-090/

...the main ISO file with 2.6.35.7 kernel is 111.6MB.

The kernel source SFS files can be downloaded from here:

http://bkhome.org/sources/
Us#er#na#me: pu#pp#y Pa#ss#wo#rd: li#nu#x

Please note that Wary 0.9 has been completely recompiled from source in T2. Wary 0.7 is an earlier compile in T2, using X.org 7.3+ versions as used in Debian Lenny, whereas 0.9 is rolled back to the original X.org 7.3.

As Wary 0.9 is intended to be the basis of a long-term Puppy-series, I have converted all the binary packages that I compiled in T2 into PETs, including _DOC and _NLS PETs and uploaded them:

http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/

...these are available in the 'puppy-wary5' repo in the Puppy package Manager (PPM). Please note that I have to do a bit of work to tidy this up, as some packages listed in PPM are already installed in Wary. I also need to tidy up how the _DOC, _DEV and _NLS packages are listed.

The 'puppy-wary5' repo has the 'mesa' package if you want to add the X.org DRI drivers for extra performance. Note, Wary already has the openGL libraries built-in. 'puppy-wary5' also has a commercial Nvidia driver PET for the 2.6.35.7 kernel for evaluation.

I have not yet uploaded the latest Woof used to build Wary 0.9.


Posted on 9 Oct 2010, 8:43


Comments:

Posted on 9 Oct 2010, 8:49 by 01micko
wary nvidia
Hi Barry
I just grabbed wary-090 (later kernel) and tried to install the nvidia pet from PPM but it fails. Could it be that PPM is looking in Puppy repo while the nvidia pet resides in the Quirky repo? That's where I found it any way and am installing that way.
Cheers


Posted on 9 Oct 2010, 9:07 by BarryK
Wary 0.9 forum feedback
I have started a forum thread for feedback:

http://murga-linux.com/puppy/viewtopic.php?t=60669



Posted on 9 Oct 2010, 15:32 by BarryK
Later Intel drivers
If anyone wants to experiment with later Intel X.org drivers, without compiling from source, Patriot created some PETs for Puppy 4.3.1 that might work, scroll down this thread:

http://www.murga-linux.com/puppy/viewtopic.php?t=44388




Posted on 9 Oct 2010, 15:35 by BarryK
Intel/libdrm versions
Note that Wary 0.9 has xf86-video-intel 2.1.1 and libdrm 2.3.0.



Posted on 9 Oct 2010, 24:12 by Terryphi
Can we add dbus?
OpenOffice appears to needs dbus. Is it possible to add it to Wary 009?


Posted on 10 Oct 2010, 7:47 by BarryK
Re dbus
Yes, certainly. Get it from the Quirky repo. Go here and download all four dbus* packages and install them:

http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-quirky/

Then reboot.

Wary has a later version of glib, but I expect the dbus from Quirky will still work.



Posted on 10 Oct 2010, 12:45 by broomdodger
xrdb -query fail
In console:
xrdb -query
wary090 fails
quirky130 ok

Well... all of xrdb fails in wary090


Posted on 10 Oct 2010, 17:10 by BarryK
Re xrdb
# xrdb -query
*font: -misc-fixed-medium-r-normal--14-130-75-75-c-70-*-*
Xft.dpi: 78

...works for me, but I'm not running a normal Wary right now, running "Wary on steroids" with Intel 2.10.0 driver.



Posted on 10 Oct 2010, 24:21 by broomdodger
xrdb fails -- more info
I was interrupted and did not finish the post.

In wary090 there is an error message when re-sourcing the .Xdefaults file, and after sourcing a changed .Xdefaults file -query prints nothing.

### wary090 ###
~# xrdb .Xdefaults
sh: cpp: command not found
xrdb -query
prints nothing

### quirky130 ###
~# xrdb .Xdefaults
~# xrdb -query
Rxvt.font: 7x14
Rxvt.saveLines: 400
Rxvt.background: LightCyan
Rxvt.cursorColor: Magenta
Rxvt.cursorColor2: Green
Rxvt.pointerColor: DarkGreen
Rxvt.pointerBlank: True
Rxvt.pointerBlankDelay: 9
Rxvt.cutchars: \\ "&'()*,;<=>?@[]^`{|}.:
Rxvt.geometry: 88x50+0+32
Rxvt.keysym.0xFF50: \033[1~
Rxvt.keysym.0xFF57: \033[4~
Rxvt.keysym.C-Home: 1G
Rxvt.keysym.C-End: G




Posted on 11 Oct 2010, 8:04 by broomdodger
xrdb fails -- even more info
It seems xrdb in wary090 works/fails the same as puppy431 but quirky130 fixed it.

Doing xrdb -h does not show any version info.

Is it xrdb or cpp or something else different?


Posted on 11 Oct 2010, 8:04 by broomdodger
xrdb fails -- even more info
It seems xrdb in wary090 works/fails the same as puppy431 but quirky130 fixed it.

Doing xrdb -h does not show any version info.

Is it xrdb or cpp or something else different?


Posted on 11 Oct 2010, 8:12 by broomdodger
xrdb fails -- cpp
I do not know how I did a double post.

ok I found it... cpp does not exist in wary090.




Posted on 11 Oct 2010, 9:15 by broomdodger
xrdb fails -- solved
I had no idea what cpp was, http://linux.die.net/man/
is my friend, man cpp.

Now dev is loaded, cpp is there and xrdb works.



Posted on 11 Oct 2010, 16:20 by Ramachandran
Wary
Dear Sir

Please check the download link. I am not able to download the Wary Puppy 0.90 from the link provided by you.


Posted on 11 Oct 2010, 17:10 by BarryK
Re Wary download
Go here to find mirrors to download from:

http://puppylinux.com/download/

...any one of the URLs with "quirky" in them.



Posted on 11 Oct 2010, 23:50 by broomdodger
Xfontsel font viewer -- missing?
Xfontsel font viewer
- wary090 does not work
+ quirky130 ok

Searched for 'xfontsel' found:
/usr/share/applications/Xfontsel-font-viewer.desktop

Clicked on the app:
Failed to execute child process "xfontsel" (No such file or directory)


Posted on 13 Oct 2010, 3:01 by L18L
NLS Packages in PPM
Suggestion for more convenience with "trim the fat"

/usr/local/petget/downloadpkgs 247 ff.
 #trim the fat...

if [ "$EXIT" = "BUTTON_TRIM_FAT" ];then
mylocales="`locale -a | grep _ | cut -d '_' -f 1 | uniq `"
INSTALLEDPKGNAMES="`echo "$INSTALLEDMSG" | cut -f 2 -d ' ' | tr '\n' ' '`"
export TRIM_DIALOG="<window title=\"Puppy Package Manager\" icon-name=\"gtk-about\">
<vbox>
<pixmap><input file>/usr/local/lib/X11/pixmaps/question.xpm</input></pixmap>
<text><label>You have chosen to 'trim the fat' of these installed packages:</label></text>
<text use-markup=\"true\"><label>\"<b>${INSTALLEDPKGNAMES}</b>\"</label></text>
<frame Locale>
<text><label>Type the 2-letter country designations for the locales that you want to retain, separated by commas. Leave blank to retain all locale files (see /usr/share/locale for examples):</label></text>
<entry><default>`echo -n $mylocales | tr ' ' ','`</default><variable>ENTRY_LOCALE</variable></entry>
</frame>

1 line added: mylocales=...
1 change: 'en' to `echo -n $mylocales | tr ' ' ','`
It will set the languages for 'trim the fat'.

Tested in wary090
0.06 sec in 1.5Ghz machine.
Regards




Posted on 13 Oct 2010, 3:14 by L18L
PPM NLS
And 'trim the fat' should be forced by default with NLS Packages.



Posted on 13 Oct 2010, 8:02 by BarryK
Re list locales
L18L,
Yes, good idea, the first one anyway. Done.



Posted on 14 Oct 2010, 2:10 by L18L
Re Re list locales
The name of the variable should better correctly be 'mylanguages' instead of 'mylocales'.

I am not sure what you are meaning by
the first one anyway ?
But anyhow I will change the script for
'trim the fat' forced by default with NLS Packages




Posted on 14 Oct 2010, 3:17 by L18L
'trim the fat' default with NLS Packages
Here it is, almost a 1-liner.
It is just suppressing the ok button if 1 of the package names is containing the string '_NLS'.
/usr/local/petget/downloadpkgs.sh 235 ff
   <label>Trim the fat</label>

<action type=\"exit\">BUTTON_TRIM_FAT</action>
</button>"
[ "`echo "$INSTALLEDMSG" | grep _NLS `" == "" ] && INSTALL_DIALOG=$INSTALL_DIALOG" <button ok></button>"
INSTALL_DIALOG=$INSTALL_DIALOG"</hbox>
</vbox>
</window>
"
export INSTALL_DIALOG

Labeling is another issue, but I think avoiding unnecessary language files is important for keeping pupsave files small.




Posted on 22 Oct 2010, 18:37 by neurino_
Won't load withoud save file?
I burned and tried to run Wary 090 on my pc having a frugal Wary 030 on it.

On first attempt it loaded my 030 save file and was was starting to `upgrade` it but I could hit reset button before any damage (I hope, at least, somebody could tell me why there's no user prompt about this... are you so sure about anyone wants to upgrade and not simply give a try before??? o_O)

Rebooted, F2, `puppy pfix=ram`: it keeps on loading my hda2/wary030/warysave.3fs file and I keep on hitting reset button...