Alternate packages for older kernel

One thing that Woof does not have is a mechanism to choose between two packages that are the same package but different versions, depending on the kernel version chosen for the build.

I have now implemented a simple mechanism. There is a variable named PKG_PREFER_OLDER in file PKGS_MANAGEMENT. There are some comments in the file that explain how it works.

The reason that this has become important to implement, is the 2.6.35.7 kernel has Aufs 2.1 and a new aufs2-util package that may not be suitable for the older Aufs 2 kernel driver. So, I have two aufs2-util packages and a simple mechanism to choose the right one.

I will also be applying this to alsa-lib and alsa-utils.


Posted on 13 Oct 2010, 20:22


No comments posted yet.