Pwallpaper 1.1.2

I can't fix Nathan's Wallpaper Setter in Wary 0.9. There are two bugs -- one of them was how the radiobuttons work and I fixed that, however the file "chooser" window hangs and that seems to be a problem with the upgraded GTK.

So, I have gone back to Pwallpaper. Previously that was crashing, but it seems to be that it needs some files out of Nathan's Wallpaper Setter.

I think that I have fixed Pwallpaper and have created a new PET 'pwallpaper-1.1.2.pet', that will be available for all Woof-built puppies. This will be in the next Wary.

Note, Lucid Puppy uses a package named 'wallpaper_lucid' and I haven't tried that in Wary.


Posted on 21 Oct 2010, 17:34


Comments:

Posted on 21 Oct 2010, 22:03 by playdayz
wallpaper_lucid
Note, Lucid Puppy uses a package named 'wallpaper_lucid' and I haven't tried that in Wary.

wallpapaer_lucid is just a collection of backgrounds. Lucid is still using Nathan's Wallpapaer Setter which seems to be working--but Lucid has not upgraded to the very latest gtk+ (which gave us trouble).


Posted on 22 Oct 2010, 8:13 by zygo
alternative wallpapers
Barry,

Does Pwallpaper allow the addition of alternative wallpapers? Nathan's doesn't allow this in Quirky 1.3.


Posted on 22 Oct 2010, 8:25 by BarryK
Re Pwallpaper
I think that Pwallpaper is hard-coded to look in /usr/share/backgrounds only. So, whatever you put in there is available to be selected.



Posted on 23 Oct 2010, 7:25 by pladyayz
oops
I was wrong about Lucid. Wallpapaer_lupu seems to be Nathan's wallpapaer setter. Sorry.