Video Upgrade Wizard

Testing Wary "093" built with 2.6.31.14 kernel.

Testing on my PC with nVidia card, I found that the Video Upgrade Wizard was broken, it reported no suitable PET to install. Fixed.

Testing on my netbook with Intel Pineview graphics, the Intel video upgrade PET worked ok. However, I found the the "video=640x480" boot parameter no longer works -- we need this when switching out of X to a console. It is not critical, just annoying as you get very small text on the console. Note, we also have this problem with the 2.6.35 kernel.

Note, the problem with "video=640x480" only affects the KMS-enabled kernel. And this only happens with the Intel video upgrade PET. With all other video drivers I am avoiding KMS -- even if/when I provide upgrades for Radeon (etc.) drivers I should be able to avoid KMS.


Posted on 27 Oct 2010, 17:02


Comments:

Posted on 27 Oct 2010, 18:34 by Iguleder
/etc/DISTRO_SPECS bug
Barry, there's a problem in /etc/DISTRO_SPECS - the comment 3builddistro adds is appended to the 14th line, after the kernel PET. Then you get lots of errors everywhere about "alpha-numeric not found".

I guess you use "echo -n" instead of "echo" ... or maybe the file lacks the line end character.


Posted on 27 Oct 2010, 19:10 by BarryK
Re missing return char
Iguleder,
Ok, I fixed it.



Posted on 27 Oct 2010, 19:16 by Iguleder
deb2ppm, fixed
Barry, I also fixed my deb2ppm script. Now it determines the package category and also knows about "Pre-Depends".

It processes the whole Debian Squeeze "main" in about one minute - I ran it three times and the results are 56, 58 and 65 seconds (with a 2createpackages running in the background) on a Core 2 Duo, 1.86 GHz.

http://brainwavedesigncentral.net/dima/deb2ppm/deb2ppm