Agere and Intel modules

The problem we have with these modules is that there are modules with the same name. The 'depmod' utility will only recognise the first that it finds of the same name. We did have a system of a symlinks to point to the module that we wanted to use, but 'depmod' ignores symlinks.

So, in the 2.6.31.14 PET package, linux_kernel-2.6.31.14-w5.pet, I have renamed the ones that we don't want to be found by default:

# find /lib/modules/2.6.31.14/agrmodem

/lib/modules/2.6.31.14/agrmodem
/lib/modules/2.6.31.14/agrmodem/11c11040
/lib/modules/2.6.31.14/agrmodem/11c11040/agrmodem.ko
/lib/modules/2.6.31.14/agrmodem/11c11040/agrserial.ko
/lib/modules/2.6.31.14/agrmodem/06pci
/lib/modules/2.6.31.14/agrmodem/06pci/agrserial.koHIDE
/lib/modules/2.6.31.14/agrmodem/06pci/agrmodem.koHIDE
/lib/modules/2.6.31.14/agrmodem/048pci
/lib/modules/2.6.31.14/agrmodem/048pci/agrserial.koHIDE
/lib/modules/2.6.31.14/agrmodem/048pci/agrmodem.koHIDE

# find /lib/modules/2.6.31.14/intelmodem
/lib/modules/2.6.31.14/intelmodem
/lib/modules/2.6.31.14/intelmodem/536EP
/lib/modules/2.6.31.14/intelmodem/536EP/Intel536.ko
/lib/modules/2.6.31.14/intelmodem/537SP
/lib/modules/2.6.31.14/intelmodem/537SP/Intel537.koHIDE
/lib/modules/2.6.31.14/intelmodem/537EA
/lib/modules/2.6.31.14/intelmodem/537EA/Intel537.koHIDE
/lib/modules/2.6.31.14/intelmodem/537
/lib/modules/2.6.31.14/intelmodem/537/Intel537.ko
/lib/modules/2.6.31.14/intelmodem/537EP
/lib/modules/2.6.31.14/intelmodem/537EP/Intel537.koHIDE


The modules that are not hidden are intended to be those most likely to be needed. So, we will need code to decide if a hidden one is needed and if so unhide it and re-run depmod. That is where rerwin comes in!

Another thing that I was wondering about is whether we should disable 'slmodemd' by default. It claims the modem on my laptop, but that has never worked. Maybe one of the PupDial probe scripts could, if it fails to find a modem, if it looks like it could be a Smartlink modem (the presence of slmodemd is indication of that), make slmodemd executable and run it, then test again for a modem ...or something like that.


Posted on 28 Oct 2010, 10:00


No comments posted yet.